summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Jolly <Matt.Jolly@footclan.ninja>2023-10-11 22:23:26 +1000
committerSam James <sam@gentoo.org>2023-10-12 07:22:50 +0100
commitad58b708797e0a9ef9e7914f818fd0e68f54e0ae (patch)
tree080892f5d187825dbf78c7ffff8fd5f98e1e7e93 /app-misc
parentapp-misc/elasticsearch: add 8.10.3 (diff)
downloadgentoo-ad58b708797e0a9ef9e7914f818fd0e68f54e0ae.tar.gz
gentoo-ad58b708797e0a9ef9e7914f818fd0e68f54e0ae.tar.bz2
gentoo-ad58b708797e0a9ef9e7914f818fd0e68f54e0ae.zip
app-misc/elasticsearch: drop 8.9.1
Signed-off-by: Matt Jolly <Matt.Jolly@footclan.ninja> Closes: https://github.com/gentoo/gentoo/pull/33300 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/elasticsearch/Manifest1
-rw-r--r--app-misc/elasticsearch/elasticsearch-8.9.1.ebuild102
2 files changed, 0 insertions, 103 deletions
diff --git a/app-misc/elasticsearch/Manifest b/app-misc/elasticsearch/Manifest
index 45ec9758af03..3f05e9665e8e 100644
--- a/app-misc/elasticsearch/Manifest
+++ b/app-misc/elasticsearch/Manifest
@@ -2,4 +2,3 @@ DIST elasticsearch-7.17.10-no-jdk-linux-x86_64.tar.gz 167971427 BLAKE2B 867f89a3
DIST elasticsearch-7.17.12-no-jdk-linux-x86_64.tar.gz 168734453 BLAKE2B b99f4df4da2a3fd1e1ecbc126148e9e2f95111a1d34bc8b6a3cc8960c33937230058cdacfd0b3e56a50db1062b5aca87f1afd9055929ac39b660b5e3715f4fce SHA512 5b6c7614c2629fdfa6c9fe9866518cd38abad0244bf7c56d8fba3894bd0493403ded0f581783deded85287cf1e97b18f45f1ffb182d3dc5ca9c96471276d64d1
DIST elasticsearch-7.17.9-no-jdk-linux-x86_64.tar.gz 167832902 BLAKE2B 9d0134fe397a5153da4936b5ac083c677a676d1a208f65a85c2c8db82cf0588d1180aeb039ed28c13161ff8fcf5bc11b0fc099f9f21d6da08e50fe0bb7f83565 SHA512 e2c6094377ed2ada0650864b7c30386467b920770b93e6f19d1448635f7f2024fbaebd619ba683ed4c1b5dc8e67f2396183d81598a5e610ca2879ea3cd8dba32
DIST elasticsearch-8.10.3-linux-x86_64.tar.gz 611634595 BLAKE2B 2a8bd089994ce31c2978b5a07d33b18379eaa3539740632a7939fa4deab1c955c0cb8ed70113a9c4c46f809087529fd527008a9122ba4b673f7a08e82c870ba5 SHA512 788354b863cf0720f8948805c8d9741bb58ca1aa34592893c9f03b7c78ddfe45c28f4470fe23ab989157b99b634db55b31e871111f62d24cda9d0fb808105f41
-DIST elasticsearch-8.9.1-linux-x86_64.tar.gz 605708895 BLAKE2B b0bbd9b6dc02ab5718616084373bf88b2de0314e6c53c9877074369ad0a122f8e225952eaaf7d72ef8762294443e0bdecf5d32387410c85a5d89432ed8b1f890 SHA512 7df7b904eacc1345ba5cbab2c933e783803ece9c8ffd4a19d3a1ab3dd883be9fbad2ca752976ca28da002253c050696295077707b3ca29088b7ed583d92444f5
diff --git a/app-misc/elasticsearch/elasticsearch-8.9.1.ebuild b/app-misc/elasticsearch/elasticsearch-8.9.1.ebuild
deleted file mode 100644
index 30abfdf800ac..000000000000
--- a/app-misc/elasticsearch/elasticsearch-8.9.1.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit systemd tmpfiles
-
-DESCRIPTION="Free and Open, Distributed, RESTful Search Engine"
-HOMEPAGE="https://www.elastic.co/elasticsearch/"
-SRC_URI="https://artifacts.elastic.co/downloads/${PN}/${P}-linux-x86_64.tar.gz"
-
-LICENSE="Apache-2.0 BSD-2 Elastic-2.0 LGPL-3 MIT public-domain"
-SLOT="0"
-KEYWORDS="~amd64"
-
-DEPEND="acct-group/elasticsearch
- acct-user/elasticsearch"
-RDEPEND="acct-group/elasticsearch
- acct-user/elasticsearch
- sys-libs/zlib
- virtual/jre:17"
-
-QA_PREBUILT="usr/share/elasticsearch/modules/x-pack-ml/platform/linux-x86_64/\(bin\|lib\)/.*"
-QA_PRESTRIPPED="usr/share/elasticsearch/modules/x-pack-ml/platform/linux-x86_64/\(bin\|lib\)/.*"
-
-PATCHES=(
- "${FILESDIR}/${PN}-env.patch"
-)
-
-src_prepare() {
- default
-
- rm -rf jdk || die
- sed -i -e "s:logs/:${EPREFIX}/var/log/${PN}/:g" config/jvm.options || die "Unable to set Elasticsearch log location"
- # elasticsearch-env sets the envvar for the config location if not specified elsewhere;
- # certain utilities try and source this. Although we patch ES_JAVA_HOME for Gentoo slightly earlier,
- # it's easier to respect EPREFIX for the config location using sed.
- sed -i "s:ES_PATH_CONF=\"\$ES_HOME\"/config:ES_PATH_CONF=\"${EPREFIX}/etc/${PN}\":" bin/elasticsearch-env \
- || die "Unable to set Elasticsearch config directory"
- rm LICENSE.txt NOTICE.txt || die
- rmdir logs || die
-}
-
-src_install() {
- keepdir /etc/${PN}
- keepdir /etc/${PN}/scripts
-
- insinto /etc/${PN}
- doins -r config/.
- rm -r config || die
-
- fowners -R root:${PN} /etc/${PN}
- fperms -R 2750 /etc/${PN}
-
- insinto /usr/share/${PN}
- doins -r .
-
- keepdir /usr/share/${PN}/plugins
-
- exeinto /usr/share/${PN}/bin
- doexe "${FILESDIR}"/elasticsearch-systemd-pre-exec
-
- fperms -R +x /usr/share/${PN}/bin
- fperms -R +x /usr/share/${PN}/modules/x-pack-ml/platform/linux-x86_64/bin
-
- keepdir /var/{lib,log}/${PN}
- fowners ${PN}:${PN} /var/{lib,log}/${PN}
- fperms 0750 /var/{lib,log}/${PN}
-
- insinto /etc/sysctl.d
- newins "${FILESDIR}/${PN}.sysctl.d" ${PN}.conf
-
- newconfd "${FILESDIR}/${PN}.conf.4" ${PN}
- newinitd "${FILESDIR}/${PN}.init.8" ${PN}
-
- systemd_install_serviced "${FILESDIR}/${PN}.service.conf"
- systemd_newunit "${FILESDIR}"/${PN}.service.4 ${PN}.service
-
- newtmpfiles "${FILESDIR}"/${PN}.tmpfiles.d ${PN}.conf
-}
-
-pkg_postinst() {
- # Elasticsearch will choke on our keep file and dodir will not preserve the empty dir
- local KEEPFILE
- KEEPFILE=$(find "${EROOT}/usr/share/${PN}/plugins/" -type f -name '.keep*')
- rm "${KEEPFILE}" || die
- tmpfiles_process /usr/lib/tmpfiles.d/${PN}.conf
- if ! systemd_is_booted ; then
- elog "You may create multiple instances of ${PN} by"
- elog "symlinking the init script:"
- elog "ln -sf /etc/init.d/${PN} /etc/init.d/${PN}.instance"
- elog
- elog "Please make sure you put elasticsearch.yml, log4j2.properties and scripts"
- elog "from /etc/${PN} into the configuration directory of the instance:"
- elog "/etc/${PN}/instance"
- elog
- fi
- ewarn "Please make sure you have proper permissions on /etc/${PN}"
- ewarn "prior to keystore generation or you may experience startup failures."
- ewarn "chown root:${PN} /etc/${PN} && chmod 2750 /etc/${PN}"
- ewarn "chown root:${PN} /etc/${PN}/${PN}.keystore && chmod 0660 /etc/${PN}/${PN}.keystore"
-}