summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2023-09-24 00:20:04 -0700
committerYixun Lan <dlan@gentoo.org>2023-10-28 10:23:47 +0000
commit3270a41702b0af68989b4da69e6bb57c149f5acd (patch)
tree5a9f4c0f59da6c4bba92f49731d00b0865dc427f /app-misc
parentapp-misc/trash-cli: drop 0.22.8.27 (diff)
downloadgentoo-3270a41702b0af68989b4da69e6bb57c149f5acd.tar.gz
gentoo-3270a41702b0af68989b4da69e6bb57c149f5acd.tar.bz2
gentoo-3270a41702b0af68989b4da69e6bb57c149f5acd.zip
app-misc/trash-cli: add 0.23.9.23
Closes: https://github.com/gentoo/gentoo/pull/33024 Signed-off-by: Zoltan Puskas <zoltan@sinustrom.info> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/trash-cli/Manifest1
-rw-r--r--app-misc/trash-cli/trash-cli-0.23.2.13.2.ebuild5
-rw-r--r--app-misc/trash-cli/trash-cli-0.23.9.23.ebuild35
3 files changed, 37 insertions, 4 deletions
diff --git a/app-misc/trash-cli/Manifest b/app-misc/trash-cli/Manifest
index eb3aacf117bb..65afc3568e75 100644
--- a/app-misc/trash-cli/Manifest
+++ b/app-misc/trash-cli/Manifest
@@ -1 +1,2 @@
DIST trash-cli-0.23.2.13.2.gh.tar.gz 104006 BLAKE2B c4187faff6618c54be3fcda2fca799d16ff614e5db2a47912aa796d72385bac8dab188977f635372372eae3f6e7d0faaea9405ac93edcd06962f6ffc2bd4694d SHA512 3894d852c01f5e3096bc5bf95220c35cfaa28e2fa555716983ad8203ce7d2206127394cdfbf3f08f0922abdbbfdb4f1a6c1db3fb0bcbda9d936612a2c7d6a7e8
+DIST trash-cli-0.23.9.23.gh.tar.gz 119568 BLAKE2B 58329ccde4ec8bbe1577b13949964766ea49ce943d6e80f7d97c6c54d38ca87297dba5197599cf52d0dd3cd02b00a6e5ddf6b3aab525b9e47bde1473c5550acd SHA512 9af243b1c7a7caa2ac303f343b425b8437f72c5b4d461badde56f46940f2c2c997fad622fa7d44dfc16c97e09044837544f2295d5df3adc96e4eb2b50efdd9c9
diff --git a/app-misc/trash-cli/trash-cli-0.23.2.13.2.ebuild b/app-misc/trash-cli/trash-cli-0.23.2.13.2.ebuild
index b77d02a9a056..8709da5fd8ca 100644
--- a/app-misc/trash-cli/trash-cli-0.23.2.13.2.ebuild
+++ b/app-misc/trash-cli/trash-cli-0.23.2.13.2.ebuild
@@ -9,10 +9,7 @@ inherit distutils-r1
DESCRIPTION="Python scripts to manipulate trash cans via the command line"
HOMEPAGE="https://github.com/andreafrancia/trash-cli"
-SRC_URI="
- https://github.com/andreafrancia/${PN}/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
+SRC_URI="https://github.com/andreafrancia/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
LICENSE="GPL-2"
SLOT="0"
diff --git a/app-misc/trash-cli/trash-cli-0.23.9.23.ebuild b/app-misc/trash-cli/trash-cli-0.23.9.23.ebuild
new file mode 100644
index 000000000000..cb2af9da5004
--- /dev/null
+++ b/app-misc/trash-cli/trash-cli-0.23.9.23.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+inherit distutils-r1
+
+DESCRIPTION="Python scripts to manipulate trash cans via the command line"
+HOMEPAGE="https://github.com/andreafrancia/trash-cli"
+SRC_URI="https://github.com/andreafrancia/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/flexmock[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ local -x COLUMNS=80
+ distutils-r1_src_test
+}