summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-04-18 21:02:26 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-04-18 21:08:31 +0000
commit249a138290c290504b38a983eeb64fefccae69ab (patch)
treef51f151ba7136db6746e7496adf1521dc2325f6a /app-misc
parentapp-doc/diveintopython: Stable for amd64. Retroactively mark stable for the r... (diff)
downloadgentoo-249a138290c290504b38a983eeb64fefccae69ab.tar.gz
gentoo-249a138290c290504b38a983eeb64fefccae69ab.tar.bz2
gentoo-249a138290c290504b38a983eeb64fefccae69ab.zip
app-misc/beep: Clean up old.
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/beep/Manifest1
-rw-r--r--app-misc/beep/beep-1.2.2-r1.ebuild27
-rw-r--r--app-misc/beep/files/beep-1.2.2-nosuid.patch33
3 files changed, 0 insertions, 61 deletions
diff --git a/app-misc/beep/Manifest b/app-misc/beep/Manifest
index 2df976f6f696..85c425a0eeaa 100644
--- a/app-misc/beep/Manifest
+++ b/app-misc/beep/Manifest
@@ -1,2 +1 @@
-DIST beep-1.2.2.tar.gz 18460 SHA256 5c0445dac43950b7c7c3f235c6fb21f620ab3fd2f3aafaf09896e5730fcf49a1 SHA512 85e2288fc01322ad2b9ad59063ee61cc94edc6b712ef1af2f86bd7e52e08cfaa81a4d8aafd729791eb3e776dbaf8fff7298ccafb758a716a3bdc9a3c385a38e1 WHIRLPOOL 845899b7f2122128833bb0b23a4eb2df576e6239e1c6df80f1abc1d1b5fddb8e80e5a500ba7bfc9638e69e5d2366aea5afdcd15c86d71304c6afe8ba1cf12868
DIST beep-1.3.tar.gz 19344 SHA256 59acef7a987de5557cefd1a904666cc2691f132929af39e65450b182a581ec2d SHA512 3f71146202208fa0c0cda360d125dd972ea003cf8cd62da21d67eb544c92f7b82640e7ce7c3835cbc65c75909a882edfa54dbd8d8b748d6f243711ea331477fd WHIRLPOOL 23ddc6e456803b82bf84b1022e5eed39488db6f4cd4410e77e55545b3e4c6256979dfc5587367c8206ea069ac4fedc4d5fa81406ea66c6c0c79fb9b428c339c7
diff --git a/app-misc/beep/beep-1.2.2-r1.ebuild b/app-misc/beep/beep-1.2.2-r1.ebuild
deleted file mode 100644
index 3a1cf3038cec..000000000000
--- a/app-misc/beep/beep-1.2.2-r1.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-inherit eutils base toolchain-funcs
-
-DESCRIPTION="The advanced PC speaker beeper"
-HOMEPAGE="http://www.johnath.com/beep/"
-SRC_URI="mirror://gentoo/${P}.tar.gz http://www.johnath.com/beep/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ppc ppc64 sparc x86"
-IUSE=""
-
-PATCHES=( ${FILESDIR}/${P}-{Makefile,nosuid}.patch )
-
-pkg_setup() {
- tc-export CC
-}
-
-src_install() {
- dobin beep
- fperms 0711 /usr/bin/beep
- doman beep.1.gz
- dodoc CHANGELOG CREDITS README
-}
diff --git a/app-misc/beep/files/beep-1.2.2-nosuid.patch b/app-misc/beep/files/beep-1.2.2-nosuid.patch
deleted file mode 100644
index 33e6affa9ffb..000000000000
--- a/app-misc/beep/files/beep-1.2.2-nosuid.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- beep.c.orig 2005-07-23 13:37:01.000000000 -0400
-+++ beep.c 2005-07-23 14:00:55.000000000 -0400
-@@ -218,22 +218,20 @@
- int i; /* loop counter */
-
- /* try to snag the console */
-- if((console_fd = open("/dev/console", O_WRONLY)) == -1) {
-- fprintf(stderr, "Could not open /dev/console for writing.\n");
-- printf("\a"); /* Output the only beep we can, in an effort to fall back on usefulness */
-- perror("open");
-- exit(1);
-- }
-+ console_fd = open("/dev/console", O_WRONLY);
-
- /* Beep */
- for (i = 0; i < parms.reps; i++) { /* start beep */
-- if(ioctl(console_fd, KIOCSOUND, (int)(CLOCK_TICK_RATE/parms.freq)) < 0) {
-- printf("\a"); /* Output the only beep we can, in an effort to fall back on usefulness */
-- perror("ioctl");
-+ if (console_fd >= 0) {
-+ ioctl(console_fd, KIOCSOUND, (int)(CLOCK_TICK_RATE/parms.freq));
-+ } else {
-+ printf("\a"); /* Output the fall back for usefulness we don't have to be suid to work at all */
-+ fflush(stdout);
- }
- /* Look ma, I'm not ansi C compatible! */
- usleep(1000*parms.length); /* wait... */
-- ioctl(console_fd, KIOCSOUND, 0); /* stop beep */
-+ if (console_fd >= 0)
-+ ioctl(console_fd, KIOCSOUND, 0); /* stop beep */
- if(parms.end_delay || (i+1 < parms.reps))
- usleep(1000*parms.delay); /* wait... */
- } /* repeat. */