summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-03-21 17:53:47 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-03-21 20:06:04 +0100
commit1e2ad588144c99bde794caa503273a883a807219 (patch)
tree44c954d5b1f7dca6e5e781c5655354ecdb896ecd /app-misc/xmind
parentmedia-fonts/essays1743: EAPI-7 bump, add IUSE="otf,ttf" (diff)
downloadgentoo-1e2ad588144c99bde794caa503273a883a807219.tar.gz
gentoo-1e2ad588144c99bde794caa503273a883a807219.tar.bz2
gentoo-1e2ad588144c99bde794caa503273a883a807219.zip
app-misc/xmind: EAPI-7 bump, add missing pkg_postrm
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-misc/xmind')
-rw-r--r--app-misc/xmind/xmind-3.7.6_p201801311814.ebuild26
1 files changed, 12 insertions, 14 deletions
diff --git a/app-misc/xmind/xmind-3.7.6_p201801311814.ebuild b/app-misc/xmind/xmind-3.7.6_p201801311814.ebuild
index 7ee0129f5e34..6dd4d5a8ae82 100644
--- a/app-misc/xmind/xmind-3.7.6_p201801311814.ebuild
+++ b/app-misc/xmind/xmind-3.7.6_p201801311814.ebuild
@@ -1,30 +1,28 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+MY_P="${PN}-8-update7-linux"
inherit desktop font optfeature xdg
-MY_PV="8-update7"
-MY_P="${PN}-${MY_PV}-linux"
-
-DESCRIPTION="A brainstorming and mind mapping software tool"
+DESCRIPTION="Brainstorming and mind mapping software tool"
HOMEPAGE="https://www.xmind.net"
SRC_URI="http://dl2.xmind.net/xmind-downloads/${MY_P}.zip
https://dev.gentoo.org/~creffett/distfiles/xmind-icons.tar.xz"
+S="${WORKDIR}"
+
LICENSE="EPL-1.0 LGPL-3"
SLOT="0"
KEYWORDS="amd64 ~x86"
IUSE=""
-DEPEND="app-arch/unzip"
+BDEPEND="app-arch/unzip"
RDEPEND="
>=virtual/jre-1.8
x11-libs/gtk+:2
"
-S=${WORKDIR}
-
QA_PRESTRIPPED="opt/xmind/XMind/libcairo-swt.so"
QA_FLAGS_IGNORED="
opt/xmind/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_1.1.400.v20160518-1444/eclipse_1617.so
@@ -36,12 +34,7 @@ FONT_SUFFIX="ttf"
FONT_S="${S}/fonts"
src_configure() {
- if use amd64; then
- XDIR="XMind_amd64"
- else
- XDIR="XMind_i386"
- fi
- mv "$XDIR" XMind || die
+ mv "XMind_$(usex amd64 amd64 i386)" XMind || die
# force data instance & config area to be at home/.xmind directory
sed \
-e '/-configuration/d' \
@@ -83,3 +76,8 @@ pkg_postinst() {
xdg_pkg_postinst
optfeature "audio notes support" media-sound/lame
}
+
+pkg_postrm() {
+ font_pkg_postrm
+ xdg_pkg_postrm
+}