summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/datovka
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/datovka')
-rw-r--r--app-misc/datovka/Manifest1
-rw-r--r--app-misc/datovka/datovka-3.0.3-r1.ebuild28
-rw-r--r--app-misc/datovka/datovka-3.0.3.ebuild37
-rw-r--r--app-misc/datovka/metadata.xml12
4 files changed, 78 insertions, 0 deletions
diff --git a/app-misc/datovka/Manifest b/app-misc/datovka/Manifest
new file mode 100644
index 000000000000..10dcb84c857a
--- /dev/null
+++ b/app-misc/datovka/Manifest
@@ -0,0 +1 @@
+DIST datovka-3.0.3.tar.gz 671555 SHA256 96bbc89fb2fe0c6a306d80260945b1b4eb089a061f9e324139b9a238d8588c3c SHA512 c3dfa23125849fb1c5691a4ad6077fedd307b8c0417c72e014876f56c1185a2da73478927fb594cac45ada77a71a3798f57a75032a4d83cd81c194fe3257397d WHIRLPOOL 4ab43452a51130ce021fd23e292f6922cd6d16670b8e65f270747b75b35b8fd085962fe6086ed3ae8f0797e4e764e5e403b7694dd82396a7c1d2b4dacb81262f
diff --git a/app-misc/datovka/datovka-3.0.3-r1.ebuild b/app-misc/datovka/datovka-3.0.3-r1.ebuild
new file mode 100644
index 000000000000..445bc53e322a
--- /dev/null
+++ b/app-misc/datovka/datovka-3.0.3-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="GUI to access Czech eGov \"Datove schranky\""
+HOMEPAGE="http://labs.nic.cz/page/969/datovka/"
+SRC_URI="http://www.nic.cz/public_media/datove_schranky/releases/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/reportlab[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ media-fonts/dejavu
+ >=net-libs/dslib-3.0[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
diff --git a/app-misc/datovka/datovka-3.0.3.ebuild b/app-misc/datovka/datovka-3.0.3.ebuild
new file mode 100644
index 000000000000..912e49f54192
--- /dev/null
+++ b/app-misc/datovka/datovka-3.0.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+
+inherit distutils
+
+DESCRIPTION="GUI to access Czech eGov \"Datove schranky\""
+HOMEPAGE="http://labs.nic.cz/page/969/datovka/"
+SRC_URI="http://www.nic.cz/public_media/datove_schranky/releases/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="
+ dev-python/pygtk:2
+ dev-python/pyopenssl
+ dev-python/reportlab
+ dev-python/sqlalchemy
+ media-fonts/dejavu
+ >=net-libs/dslib-3.0
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -r 4 "${WORKDIR}"
+}
diff --git a/app-misc/datovka/metadata.xml b/app-misc/datovka/metadata.xml
new file mode 100644
index 000000000000..416ef33f0839
--- /dev/null
+++ b/app-misc/datovka/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<longdescription>
+ A GUI for accessing ISDS (Informační systém datových schránek
+ / Data Box Information System) SOAP services as defined in Czech ISDS Act
+ (300/2008 Coll.) and implied documents.
+</longdescription>
+<maintainer>
+ <email>scarabeus@gentoo.org</email>
+</maintainer>
+</pkgmetadata>