summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2024-05-25 15:06:41 -0700
committerGöktürk Yüksek <gokturk@gentoo.org>2024-05-25 15:08:04 -0700
commitcd1930ade8c20a9420edaa787b0eea3af344c9ce (patch)
treedd5306b56ed2fd55bd9e2a310cdd931f161dae5e /app-laptop
parentvirtual/perl-Math-Complex: add 5.40 as provider (diff)
downloadgentoo-cd1930ade8c20a9420edaa787b0eea3af344c9ce.tar.gz
gentoo-cd1930ade8c20a9420edaa787b0eea3af344c9ce.tar.bz2
gentoo-cd1930ade8c20a9420edaa787b0eea3af344c9ce.zip
app-laptop/mbpfan: add 2.4.0
Signed-off-by: Göktürk Yüksek <gokturk@gentoo.org>
Diffstat (limited to 'app-laptop')
-rw-r--r--app-laptop/mbpfan/Manifest1
-rw-r--r--app-laptop/mbpfan/mbpfan-2.4.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/app-laptop/mbpfan/Manifest b/app-laptop/mbpfan/Manifest
index 4b37381766b0..a3c85e154d5c 100644
--- a/app-laptop/mbpfan/Manifest
+++ b/app-laptop/mbpfan/Manifest
@@ -1 +1,2 @@
DIST mbpfan-2.3.0.tar.gz 40984 BLAKE2B ac593e94ee5915935767b221b3f8b29d416fadf3294b4930ba1b441838758c5014dc960c90e5ce35e3475793aaf68b2981641323dd9ea22dd50772cd54f75078 SHA512 676817d7d9b9e9fa866539d4b0e3edc8d0d22761807695961451fe1d5845c22031d45f53222d37c5ed967757b4cf80523a3af7d28084d9af11248798a463cdfd
+DIST mbpfan-2.4.0.tar.gz 41723 BLAKE2B 91efc640a3d5d73fff61fd9c323a5ba82dae1bc55cfa9486b6ab657f5af3c2ecda5bd53c835a5d1ad3af42a6b3198a812a115fa8cc535d643f01f20d34818ded SHA512 fa906043552a895d274642dfe8e3a94fdece0bf9b430710d9ee4dc4f33b6762fbed3314e4a67ede11916514297d511031cc99b35b7a267b58aceefd73e4b1d22
diff --git a/app-laptop/mbpfan/mbpfan-2.4.0.ebuild b/app-laptop/mbpfan/mbpfan-2.4.0.ebuild
new file mode 100644
index 000000000000..71a3676ade72
--- /dev/null
+++ b/app-laptop/mbpfan/mbpfan-2.4.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info systemd toolchain-funcs
+
+DESCRIPTION="A simple daemon to control fan speed on all Macbook/Macbook Pros"
+HOMEPAGE="https://github.com/dgraziotin/mbpfan"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dgraziotin/${PN}.git"
+else
+ SRC_URI="https://github.com/dgraziotin/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+RESTRICT="test" # will fail if the hardware is unavailable, not useful
+
+CONFIG_CHECK="~SENSORS_APPLESMC ~SENSORS_CORETEMP"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.3.0-clang16-build-fix.patch
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+
+ # Decompress the man page to enable PM auto compression
+ gzip -d "${ED}"/usr/share/man/man8/mbpfan.8.gz || die
+
+ # Remove the empty systemd unit directory
+ # It doesn't actually install the unit file
+ rmdir --ignore-fail-on-non-empty -p "${ED}"/lib/systemd/system || die
+ # Actually install the sytstemd unit file
+ systemd_dounit ${PN}.service
+ # Install openrc init file
+ newinitd ${PN}.init.gentoo ${PN}
+ # mbpfan-2.4.0 adds support for dinit (https://github.com/davmac314/dinit)
+ # As of writing this, dinit is not in the tree.
+
+ # make install doesn't install the docs in the right place
+ rm -r "${ED}"/usr/share/doc/${PN} || die
+
+ einstalldocs
+}