summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-18 14:47:58 +0000
committerSam James <sam@gentoo.org>2024-03-18 14:51:34 +0000
commitfe64d8bd46d8e8859d6442e34766bf423121fc11 (patch)
tree8820d5b75d65ed53ebfa5760cceb20390eec967b /app-eselect
parentxfce-base/xfce4-settings: fix undefined references (diff)
downloadgentoo-fe64d8bd46d8e8859d6442e34766bf423121fc11.tar.gz
gentoo-fe64d8bd46d8e8859d6442e34766bf423121fc11.tar.bz2
gentoo-fe64d8bd46d8e8859d6442e34766bf423121fc11.zip
app-eselect/eselect-pinentry: add 0.7.4
Adds pinentry-qt6 support. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-eselect')
-rw-r--r--app-eselect/eselect-pinentry/eselect-pinentry-0.7.4.ebuild19
-rw-r--r--app-eselect/eselect-pinentry/files/pinentry.eselect-0.7.420
2 files changed, 39 insertions, 0 deletions
diff --git a/app-eselect/eselect-pinentry/eselect-pinentry-0.7.4.ebuild b/app-eselect/eselect-pinentry/eselect-pinentry-0.7.4.ebuild
new file mode 100644
index 000000000000..2f34f9567def
--- /dev/null
+++ b/app-eselect/eselect-pinentry/eselect-pinentry-0.7.4.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Manage /usr/bin/pinentry symlink"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Eselect"
+S="${WORKDIR}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+
+RDEPEND=">=app-eselect/eselect-lib-bin-symlink-0.1.1"
+
+src_install() {
+ insinto /usr/share/eselect/modules
+ newins "${FILESDIR}"/pinentry.eselect-${PV} pinentry.eselect
+}
diff --git a/app-eselect/eselect-pinentry/files/pinentry.eselect-0.7.4 b/app-eselect/eselect-pinentry/files/pinentry.eselect-0.7.4
new file mode 100644
index 000000000000..74c6f14d8b53
--- /dev/null
+++ b/app-eselect/eselect-pinentry/files/pinentry.eselect-0.7.4
@@ -0,0 +1,20 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="Manage /usr/bin/pinentry implementation"
+MAINTAINER="maintainer-needed@gentoo.org"
+VERSION="0.7.4"
+
+SYMLINK_PATH=/usr/bin/pinentry
+SYMLINK_TARGETS=(
+ pinentry-efl
+ pinentry-gnome3
+ pinentry-qt5
+ pinentry-qt6
+ pinentry-curses
+ pinentry-tty
+ pinentry-emacs
+)
+SYMLINK_DESCRIPTION='pinentry binary'
+
+inherit bin-symlink