summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-11-23 18:06:31 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-11-23 18:23:10 -0500
commit6b1f163badeb7a401008ac375875438898db97f6 (patch)
treedf2579558910ecdeaf3141d3da855db9c139a475 /app-emulation
parentdev-util/idea-community: drop 2022.2.3 (diff)
downloadgentoo-6b1f163badeb7a401008ac375875438898db97f6.tar.gz
gentoo-6b1f163badeb7a401008ac375875438898db97f6.tar.bz2
gentoo-6b1f163badeb7a401008ac375875438898db97f6.zip
app-emulation/wine-vanilla: adjust mold workaround
-version worked fine but is not correct (typo), so replace it (--version emits collect2 noise, so also add 2>/dev/null) Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-7.0-r3.ebuild2
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-7.0.1.ebuild2
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-7.19.ebuild2
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-7.20.ebuild2
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-7.21.ebuild2
-rw-r--r--app-emulation/wine-vanilla/wine-vanilla-9999.ebuild2
6 files changed, 6 insertions, 6 deletions
diff --git a/app-emulation/wine-vanilla/wine-vanilla-7.0-r3.ebuild b/app-emulation/wine-vanilla/wine-vanilla-7.0-r3.ebuild
index dc2e4068edcf..653e8809117b 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-7.0-r3.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-7.0-r3.ebuild
@@ -224,7 +224,7 @@ src_configure() {
# temporary workaround for tc-ld-force-bfd not yet enforcing with mold
# https://github.com/gentoo/gentoo/pull/28355
- [[ $($(tc-getCC) ${LDFLAGS} -Wl,-version) == mold* ]] &&
+ [[ $($(tc-getCC) ${LDFLAGS} -Wl,--version 2>/dev/null) == mold* ]] &&
append-ldflags -fuse-ld=bfd
# build using upstream's way (--with-wine64)
diff --git a/app-emulation/wine-vanilla/wine-vanilla-7.0.1.ebuild b/app-emulation/wine-vanilla/wine-vanilla-7.0.1.ebuild
index 9b11369147f9..da66b3163208 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-7.0.1.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-7.0.1.ebuild
@@ -224,7 +224,7 @@ src_configure() {
# temporary workaround for tc-ld-force-bfd not yet enforcing with mold
# https://github.com/gentoo/gentoo/pull/28355
- [[ $($(tc-getCC) ${LDFLAGS} -Wl,-version) == mold* ]] &&
+ [[ $($(tc-getCC) ${LDFLAGS} -Wl,--version 2>/dev/null) == mold* ]] &&
append-ldflags -fuse-ld=bfd
# build using upstream's way (--with-wine64)
diff --git a/app-emulation/wine-vanilla/wine-vanilla-7.19.ebuild b/app-emulation/wine-vanilla/wine-vanilla-7.19.ebuild
index fe719b45b565..69628d775f7e 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-7.19.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-7.19.ebuild
@@ -222,7 +222,7 @@ src_configure() {
# temporary workaround for tc-ld-force-bfd not yet enforcing with mold
# https://github.com/gentoo/gentoo/pull/28355
- [[ $($(tc-getCC) ${LDFLAGS} -Wl,-version) == mold* ]] &&
+ [[ $($(tc-getCC) ${LDFLAGS} -Wl,--version 2>/dev/null) == mold* ]] &&
append-ldflags -fuse-ld=bfd
# build using upstream's way (--with-wine64)
diff --git a/app-emulation/wine-vanilla/wine-vanilla-7.20.ebuild b/app-emulation/wine-vanilla/wine-vanilla-7.20.ebuild
index 47b47b73effa..e1d2da19d47b 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-7.20.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-7.20.ebuild
@@ -222,7 +222,7 @@ src_configure() {
# temporary workaround for tc-ld-force-bfd not yet enforcing with mold
# https://github.com/gentoo/gentoo/pull/28355
- [[ $($(tc-getCC) ${LDFLAGS} -Wl,-version) == mold* ]] &&
+ [[ $($(tc-getCC) ${LDFLAGS} -Wl,--version 2>/dev/null) == mold* ]] &&
append-ldflags -fuse-ld=bfd
# build using upstream's way (--with-wine64)
diff --git a/app-emulation/wine-vanilla/wine-vanilla-7.21.ebuild b/app-emulation/wine-vanilla/wine-vanilla-7.21.ebuild
index f89a31c6613d..d931d7219d8d 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-7.21.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-7.21.ebuild
@@ -223,7 +223,7 @@ src_configure() {
# temporary workaround for tc-ld-force-bfd not yet enforcing with mold
# https://github.com/gentoo/gentoo/pull/28355
- [[ $($(tc-getCC) ${LDFLAGS} -Wl,-version) == mold* ]] &&
+ [[ $($(tc-getCC) ${LDFLAGS} -Wl,--version 2>/dev/null) == mold* ]] &&
append-ldflags -fuse-ld=bfd
# build using upstream's way (--with-wine64)
diff --git a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
index 5bb1c8a10d53..b73eb356b435 100644
--- a/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
+++ b/app-emulation/wine-vanilla/wine-vanilla-9999.ebuild
@@ -219,7 +219,7 @@ src_configure() {
# temporary workaround for tc-ld-force-bfd not yet enforcing with mold
# https://github.com/gentoo/gentoo/pull/28355
- [[ $($(tc-getCC) ${LDFLAGS} -Wl,-version) == mold* ]] &&
+ [[ $($(tc-getCC) ${LDFLAGS} -Wl,--version 2>/dev/null) == mold* ]] &&
append-ldflags -fuse-ld=bfd
# build using upstream's way (--with-wine64)