summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2022-05-03 18:33:31 +0000
committerSam James <sam@gentoo.org>2022-05-03 19:41:17 +0100
commit0828d17d30acd44d5843198fa4b5a935a2c6d897 (patch)
treed88ad83b0da076ad52113505f31f7937fb331568 /app-emulation
parentapp-emulation/xen: drop vulnerable (diff)
downloadgentoo-0828d17d30acd44d5843198fa4b5a935a2c6d897.tar.gz
gentoo-0828d17d30acd44d5843198fa4b5a935a2c6d897.tar.bz2
gentoo-0828d17d30acd44d5843198fa4b5a935a2c6d897.zip
app-emulation/xen-tools: replace dev-python/pypam with sys-libs/pam
It was discovered that pypam is no longer needed for xen-tools. Upstream is dead anyway. Qemu-xen checks for pam, so we add a dep on sys-libs/pam for USE=qemu. Bug: https://bugs.gentoo.org/833297 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/25302 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/xen-tools/xen-tools-4.15.2-r1.ebuild5
-rw-r--r--app-emulation/xen-tools/xen-tools-4.16.0-r3.ebuild11
2 files changed, 8 insertions, 8 deletions
diff --git a/app-emulation/xen-tools/xen-tools-4.15.2-r1.ebuild b/app-emulation/xen-tools/xen-tools-4.15.2-r1.ebuild
index 2f6e74c4eca4..2314461098b0 100644
--- a/app-emulation/xen-tools/xen-tools-4.15.2-r1.ebuild
+++ b/app-emulation/xen-tools/xen-tools-4.15.2-r1.ebuild
@@ -69,7 +69,7 @@ SLOT="0/$(ver_cut 1-2)"
# Inclusion of IUSE ocaml on stabalizing requires maintainer of ocaml to (get off his hands and) make
# >=dev-lang/ocaml-4 stable
# Masked in profiles/eapi-5-files instead
-IUSE="api debug doc +hvm +ipxe ocaml ovmf +pam pygrub python +qemu +qemu-traditional +rombios screen selinux sdl static-libs system-ipxe system-qemu system-seabios"
+IUSE="api debug doc +hvm +ipxe ocaml ovmf pygrub python +qemu +qemu-traditional +rombios screen selinux sdl static-libs system-ipxe system-qemu system-seabios"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
@@ -82,6 +82,7 @@ REQUIRED_USE="
?? ( qemu system-qemu )"
COMMON_DEPEND="
+ qemu? ( sys-libs/pam )
sys-apps/pciutils
dev-libs/lzo:2
dev-libs/glib:2
@@ -107,7 +108,6 @@ DEPEND="${COMMON_DEPEND}
x11-libs/pixman
$(python_gen_cond_dep '
dev-python/lxml[${PYTHON_USEDEP}]
- pam? ( dev-python/pypam[${PYTHON_USEDEP}] )
')
x86? ( sys-devel/dev86
system-ipxe? ( sys-firmware/ipxe[qemu] )
@@ -430,7 +430,6 @@ src_configure() {
$(usex system-ipxe '--with-system-ipxe=/usr/share/ipxe' '') \
$(use_enable ocaml ocamltools) \
$(use_enable ovmf) \
- $(use_enable pam) \
$(use_enable rombios) \
--with-xenstored=$(usex ocaml 'oxenstored' 'xenstored') \
"
diff --git a/app-emulation/xen-tools/xen-tools-4.16.0-r3.ebuild b/app-emulation/xen-tools/xen-tools-4.16.0-r3.ebuild
index 5d286bc55afe..d47a25185322 100644
--- a/app-emulation/xen-tools/xen-tools-4.16.0-r3.ebuild
+++ b/app-emulation/xen-tools/xen-tools-4.16.0-r3.ebuild
@@ -69,7 +69,7 @@ SLOT="0/$(ver_cut 1-2)"
# Inclusion of IUSE ocaml on stabalizing requires maintainer of ocaml to (get off his hands and) make
# >=dev-lang/ocaml-4 stable
# Masked in profiles/eapi-5-files instead
-IUSE="api debug doc +hvm +ipxe lzma ocaml ovmf +pam pygrub python +qemu +qemu-traditional +rombios screen selinux sdl static-libs system-ipxe system-qemu system-seabios systemd zstd"
+IUSE="api debug doc +hvm +ipxe lzma ocaml ovmf pygrub python +qemu +qemu-traditional +rombios screen selinux sdl static-libs system-ipxe system-qemu system-seabios systemd zstd"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
@@ -83,7 +83,10 @@ REQUIRED_USE="
COMMON_DEPEND="
lzma? ( app-arch/xz-utils )
- qemu? ( dev-libs/glib:2 )
+ qemu? (
+ dev-libs/glib:2
+ sys-libs/pam
+ )
zstd? ( app-arch/zstd )
app-arch/bzip2
app-arch/zstd
@@ -112,7 +115,6 @@ DEPEND="${COMMON_DEPEND}
x11-libs/pixman
$(python_gen_cond_dep '
dev-python/lxml[${PYTHON_USEDEP}]
- pam? ( dev-python/pypam[${PYTHON_USEDEP}] )
')
x86? ( sys-devel/dev86
system-ipxe? ( sys-firmware/ipxe[qemu] )
@@ -417,7 +419,7 @@ src_prepare() {
# Remove -Werror
find . -type f \( -name Makefile -o -name "*.mk" \) \
- -exec sed -i "s/-Werror //g" {} + || die
+ -exec sed -i "s/-Werror //g" {} + || die
default
}
@@ -437,7 +439,6 @@ src_configure() {
$(usex system-ipxe '--with-system-ipxe=/usr/share/ipxe' '')
$(use_enable ocaml ocamltools)
$(use_enable ovmf)
- $(use_enable pam)
$(use_enable rombios)
$(use_enable systemd)
--with-xenstored=$(usex ocaml 'oxenstored' 'xenstored')