summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-04-20 12:54:41 +0200
committerDavid Seifert <soap@gentoo.org>2021-04-20 12:54:41 +0200
commit7eb5f9d25bc73d00ddd0b10df50e14feee8cc569 (patch)
tree0f9ed6dd808bfe76c7b9734ac36de60ee02be4cc /app-emulation/xcpc
parentx11-plugins/pidgin-gnome-keyring: fix pkgconfig calls in the Makefile (diff)
downloadgentoo-7eb5f9d25bc73d00ddd0b10df50e14feee8cc569.tar.gz
gentoo-7eb5f9d25bc73d00ddd0b10df50e14feee8cc569.tar.bz2
gentoo-7eb5f9d25bc73d00ddd0b10df50e14feee8cc569.zip
app-emulation/xcpc: Bump to 0.35.0
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-emulation/xcpc')
-rw-r--r--app-emulation/xcpc/Manifest1
-rw-r--r--app-emulation/xcpc/xcpc-0.35.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/app-emulation/xcpc/Manifest b/app-emulation/xcpc/Manifest
index 202bdb898f57..bf09a91920d9 100644
--- a/app-emulation/xcpc/Manifest
+++ b/app-emulation/xcpc/Manifest
@@ -1 +1,2 @@
+DIST xcpc-0.35.0.tar.gz 1058202 BLAKE2B f5002fcc69a078cd05c05a981522edd15900295136419157f997effd81a89f7452cec335bbdba0be3b303bdc8f8537d4aac255ee7cf4e9ec53cc1143413ad1c1 SHA512 667db6db33f2cab85647960edb5b1c200037bfc464527a60eca85c31549360226893853a38d98e657bde111a28aca47d9741b16b13284759b66cb6213da27458
DIST xcpc-20070122.tar.gz 496627 BLAKE2B 13fc9974e3810fa4ef45e90764641cb0a220657055829d1ec9a185c1a894234d3a654581e317327ac5937454b9dfab14af2654775157041edcc0176975753835 SHA512 7f5700340fbbf23d2f2111e31ce803c846799ef6681cf63e28bc67564e092534fc4140cb99d718fae9126668ee8f3053bbd097537c04637b5b809ce7b986dd26
diff --git a/app-emulation/xcpc/xcpc-0.35.0.ebuild b/app-emulation/xcpc/xcpc-0.35.0.ebuild
new file mode 100644
index 000000000000..4bf1ea8845d0
--- /dev/null
+++ b/app-emulation/xcpc/xcpc-0.35.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg
+
+DESCRIPTION="XCPC is a portable Amstrad CPC 464/664/6128 emulator written in C."
+HOMEPAGE="http://www.xcpc-emulator.net/doku.php/index"
+SRC_URI="https://bitbucket.org/ponceto/xcpc/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ app-arch/bzip2
+ sys-libs/zlib
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXext
+ x11-libs/libXt"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf \
+ --enable-athena \
+ --disable-motif2
+}