summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-08-10 08:43:02 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-08-10 08:43:05 -0400
commitaac26b5d3bd519a3d12610ae13f6e90072cbbb2e (patch)
treea881b838bc08e5f9a0cff9c7b55678720e5354e9 /app-emulation/wine-staging/wine-staging-8.13.ebuild
parentapp-emulation/wine-vanilla: add postinst ewarn to advertise wow64 (diff)
downloadgentoo-aac26b5d3bd519a3d12610ae13f6e90072cbbb2e.tar.gz
gentoo-aac26b5d3bd519a3d12610ae13f6e90072cbbb2e.tar.bz2
gentoo-aac26b5d3bd519a3d12610ae13f6e90072cbbb2e.zip
app-emulation/wine-staging: add postinst ewarn to advertise wow64
Didn't want to add this a before given some profiles do not even leave a choice, but now it feels a build without 32bit is just a disservice. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'app-emulation/wine-staging/wine-staging-8.13.ebuild')
-rw-r--r--app-emulation/wine-staging/wine-staging-8.13.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/app-emulation/wine-staging/wine-staging-8.13.ebuild b/app-emulation/wine-staging/wine-staging-8.13.ebuild
index 6edbd663cb04..3a7cda74ca11 100644
--- a/app-emulation/wine-staging/wine-staging-8.13.ebuild
+++ b/app-emulation/wine-staging/wine-staging-8.13.ebuild
@@ -410,6 +410,13 @@ src_install() {
}
pkg_postinst() {
+ if use !abi_x86_32 && use !wow64; then
+ ewarn "32bit support is disabled. While 64bit applications themselves will"
+ ewarn "work, be warned that it is not unusual that installers or other helpers"
+ ewarn "will attempt to use 32bit and fail. If do not want full USE=abi_x86_32,"
+ ewarn "note that the experimental USE=wow64 can allow 32bit without multilib."
+ fi
+
eselect wine update --if-unset || die
}