summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-11-22 23:20:13 +0000
committerJames Le Cuirot <chewi@gentoo.org>2021-11-22 23:21:04 +0000
commit1462b4ea0eaec237297631d3c21c5edca21d70ed (patch)
tree5315f4216c764bd07eaa09f6bcf73dde6ee5ec29 /app-emulation/fs-uae-launcher
parentapp-emulation/fs-uae: Version bump to 3.1.59 (diff)
downloadgentoo-1462b4ea0eaec237297631d3c21c5edca21d70ed.tar.gz
gentoo-1462b4ea0eaec237297631d3c21c5edca21d70ed.tar.bz2
gentoo-1462b4ea0eaec237297631d3c21c5edca21d70ed.zip
app-emulation/fs-uae-launcher: Version bump to 3.1.46
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'app-emulation/fs-uae-launcher')
-rw-r--r--app-emulation/fs-uae-launcher/Manifest1
-rw-r--r--app-emulation/fs-uae-launcher/fs-uae-launcher-3.1.46.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/app-emulation/fs-uae-launcher/Manifest b/app-emulation/fs-uae-launcher/Manifest
index 588095e995c0..a0fb4b3777af 100644
--- a/app-emulation/fs-uae-launcher/Manifest
+++ b/app-emulation/fs-uae-launcher/Manifest
@@ -1,2 +1,3 @@
DIST fs-uae-launcher-3.1.26.tar.gz 9656516 BLAKE2B 1b8d12ef91631dedf412976e81529ac7138b7f688ad6ae1ad55bfd3625590ee00aab89d229d2aa64eec577d291a6e634362c557428534c355fdb39e878f40253 SHA512 0e4e542bebfe2d8f862005c016fe70319dd6c5e1e413be9b0ce0421bb95253ba6eb92337989cc86210094b9b02a6ad86da4725f1a65d50673703fa6c6cb58f37
DIST fs-uae-launcher-3.1.43.tar.xz 7785544 BLAKE2B 504d97dbc2bff7bc6abe065854e51b1ce51d40aec582586473629a77626c750510b4f885d3679a734d2dc7c889e9b18f41c27ea924ea7134641de2df16a0b404 SHA512 df19c4a3897b089daaee869226dfe2adfa990e0f8e30772e482e27a21c64f7d9d3369e8d6b0c72ac6119e207e9978f2052a7d681fe4f40b99e5ec48161e2a0fe
+DIST fs-uae-launcher-3.1.46.tar.xz 7820988 BLAKE2B 9c6bb28c00a41f71067d13ec40f947bf20d447dcc32b3d1e9053204b70699bc6b8ad89776421a8feb6ecad325b320e4b11e32abd65002650583c14890a41f85c SHA512 f96d01a0e2f985e02238fde482457d1859e04bde3c5a43dfbabc47c57ae7fea89970174931d95eb1679fc1ef6be0d52bef40e33f8d66e79fd0327af863290c06
diff --git a/app-emulation/fs-uae-launcher/fs-uae-launcher-3.1.46.ebuild b/app-emulation/fs-uae-launcher/fs-uae-launcher-3.1.46.ebuild
new file mode 100644
index 000000000000..1ed6d4b64f52
--- /dev/null
+++ b/app-emulation/fs-uae-launcher/fs-uae-launcher-3.1.46.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8,9} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1 xdg
+
+DESCRIPTION="PyQt5-based launcher for FS-UAE"
+HOMEPAGE="https://fs-uae.net/"
+SRC_URI="https://fs-uae.net/files/FS-UAE-Launcher/Stable/${PV}/${P}.tar.xz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+IUSE="lha"
+RESTRICT="test" # The test files are just boilerplate.
+
+RDEPEND="
+ app-emulation/fs-uae
+ $(python_gen_cond_dep '
+ dev-python/PyQt5[${PYTHON_USEDEP},declarative,gui,network,opengl,widgets]
+ dev-python/pyopengl[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ lha? ( dev-python/python-lhafile[${PYTHON_USEDEP}] )
+ ')
+"
+
+BDEPEND="
+ sys-devel/gettext
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0.0-ROMs.patch
+)
+
+python_compile_all() {
+ emake
+}
+
+python_install() {
+ local dir=${EPREFIX}/usr/share/${PN}
+ distutils-r1_python_install --install-lib="${dir}" --install-scripts="${dir}"
+}
+
+python_install_all() {
+ dosym ../share/${PN}/${PN} /usr/bin/${PN}
+ emake install-data DESTDIR="${D}" prefix="${EPREFIX}"/usr
+ mv "${ED}"/usr/share/doc/{${PN},${PF}} || die
+}
+
+pkg_postinst() {
+ elog "Some important information:"
+ elog
+ ewarn " - Do not use QtCurve, it will crash PyQt5!"
+ elog
+ elog " - By default, FS-UAE creates its directories under Documents/FS-UAE."
+ elog " If your Documents directory is not configured according to the XDG"
+ elog " user diretory spec, ~/FS-UAE will be used as a fallback."
+ elog
+ elog " - You can override this by putting the path to the desired base"
+ elog " directory in a special config file. The config file will be read"
+ elog " from ~/.config/fs-uae/base-dir by both FS-UAE and FS-UAE Launcher"
+ elog " if it exists."
+ elog
+ elog " Alternatively, you can start FS-UAE and/or FS-UAE Launcher with"
+ elog " --base-dir=/path/to/desired/dir"
+}