summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-11-17 16:39:07 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-11-17 17:26:47 +0100
commit2bf6c73195078a507d9b2eda2928d57cd30fd781 (patch)
treef83d9733f431b45c7640a6e76e2faf60e0a31161 /app-emacs
parentgames-emulation/ppsspp: bump to 1.18.1 (diff)
downloadgentoo-2bf6c73195078a507d9b2eda2928d57cd30fd781.tar.gz
gentoo-2bf6c73195078a507d9b2eda2928d57cd30fd781.tar.bz2
gentoo-2bf6c73195078a507d9b2eda2928d57cd30fd781.zip
app-emacs/ef-themes: bump to 1.9.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/ef-themes/Manifest1
-rw-r--r--app-emacs/ef-themes/ef-themes-1.9.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-emacs/ef-themes/Manifest b/app-emacs/ef-themes/Manifest
index 5b5077f4b868..79d07d0f4e1a 100644
--- a/app-emacs/ef-themes/Manifest
+++ b/app-emacs/ef-themes/Manifest
@@ -1,2 +1,3 @@
DIST ef-themes-1.7.0.tar.gz 180301 BLAKE2B f9e0c152cc19c60ccfe27036d33e274d50deee016d56f154ca1cce5350bd3c23bcf73005ea890226e9e665cc284fb1e4e1328a0a66d79f0abb2b725c4d2780f4 SHA512 07cce282ea87af53349195b0fe35d1c89156f3456f09ababe3dbacdb2a00bc90f505d935504d6cd5f5fd6ef4f997102269e854ec4cea4c35441e3b5118f2b7d1
DIST ef-themes-1.8.0.tar.gz 185303 BLAKE2B 6f5e76ed70e08a42abfead6109b62d4c463166238c9f0a531be4c826109d359008348d38bab09a9d343ae4b8302526d64ccedefb8d58bafa39177d12f66e0e73 SHA512 60a7fe6bb6846f10bf5cbc1a4ae55e212d77f551f619bf3f99e06ac2c789e9f854098e2c841c544d22b82509a175ee52c05f5365ff665a723f64d0b8c788b11a
+DIST ef-themes-1.9.0.tar.gz 188944 BLAKE2B 0ed9baba95408d84b5724df674c62197f65541e9c95a0a2bfc3b3979b41e5ee4eb99a1019b9ea0bd7d9b23859e224db58618c424796ef5c91050c357fa79108e SHA512 6beb0571cfe10c454db4878aaaa8f7fbd630ac24064b3f08b909fc7430b320c7340d7c49b6449e535b86eade6dcc191f2fd6154354890d96129be3ff43d5dad8
diff --git a/app-emacs/ef-themes/ef-themes-1.9.0.ebuild b/app-emacs/ef-themes/ef-themes-1.9.0.ebuild
new file mode 100644
index 000000000000..80527024d575
--- /dev/null
+++ b/app-emacs/ef-themes/ef-themes-1.9.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS="27.1"
+
+inherit elisp
+
+DESCRIPTION="Colourful and legible themes for GNU Emacs"
+HOMEPAGE="https://github.com/protesilaos/ef-themes/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/protesilaos/${PN}.git"
+else
+ SRC_URI="https://github.com/protesilaos/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+DOCS=( CHANGELOG.org README.md README.org contrast-ratios.org )
+ELISP_TEXINFO="${PN}.texi"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-org-export-to texinfo README.org
+
+ elisp_src_compile
+ elisp-make-autoload-file
+}