summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-05-21 21:02:34 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-05-21 21:04:06 +0200
commit1b3c72c9adcc708f2819e052c4db81566d6d4bfa (patch)
tree28ca3cc69f46e8fb9dfd4db73bd41bdd87f402fc /app-emacs
parentdev-dotnet/fsautocomplete: bump to 0.73.0 (diff)
downloadgentoo-1b3c72c9adcc708f2819e052c4db81566d6d4bfa.tar.gz
gentoo-1b3c72c9adcc708f2819e052c4db81566d6d4bfa.tar.bz2
gentoo-1b3c72c9adcc708f2819e052c4db81566d6d4bfa.zip
app-emacs/auctex: bump to 14.0.5
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/auctex/Manifest1
-rw-r--r--app-emacs/auctex/auctex-14.0.5.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/app-emacs/auctex/Manifest b/app-emacs/auctex/Manifest
index 8e022ae758eb..401664be1fd8 100644
--- a/app-emacs/auctex/Manifest
+++ b/app-emacs/auctex/Manifest
@@ -1 +1,2 @@
DIST auctex-13.3.tar.gz 1695608 BLAKE2B 3a22273b72237e14a31a1fb9d81e2c4ee10290919bc3d6f8cb35ab877ef26083c7edb5bbb7c88a40f45848012cc2edd375a90d872f604029ba8f03278bd95f9a SHA512 32d6f3c968a27dd5e7862993419bfa0f5e5228abca7478341a06fce153f333410cd230f8266e6b0e4fb5e4247864710e3f572b6a837c99c2879d38899590f678
+DIST auctex-14.0.5.tar.gz 1342079 BLAKE2B 0c61c2c4f4882af72eaff1e7ecb1429d1313429e1b08fdc94d9c3b3c8fc1df06b2df5a30ecbc49b42cfd1df7ee1a2540cb743467c6ae6d4cb96380e1253c3341 SHA512 88a517d385d1bed3f0876e024c8d454cf5576eeb0149785da8035531eb2d4169e128574da31fa610aedbe2b54507b53964cdf6f4f81a163c4ade24462b849439
diff --git a/app-emacs/auctex/auctex-14.0.5.ebuild b/app-emacs/auctex/auctex-14.0.5.ebuild
new file mode 100644
index 000000000000..50646ef6965a
--- /dev/null
+++ b/app-emacs/auctex/auctex-14.0.5.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools elisp
+
+DESCRIPTION="Extensible package for writing and formatting TeX files in Emacs"
+HOMEPAGE="https://www.gnu.org/software/auctex/
+ https://git.savannah.gnu.org/cgit/auctex.git"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://git.savannah.gnu.org/git/${PN}.git"
+else
+ [[ "${PV}" == 14.0.5 ]] && COMMIT_SHA="e30189d92a701ab22a69a09fe2b9e9619fff6ce8"
+
+ SRC_URI="https://git.savannah.gnu.org/cgit/${PN}.git/snapshot/${PN}-${COMMIT_SHA}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${COMMIT_SHA}"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+fi
+
+LICENSE="GPL-3+ FDL-1.3+"
+SLOT="0"
+IUSE="preview-latex"
+
+RDEPEND="
+ virtual/latex-base
+ preview-latex? (
+ app-text/dvipng
+ app-text/ghostscript-gpl
+ )
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+TEXMF="/usr/share/texmf-site"
+
+src_prepare() {
+ elisp_src_prepare
+
+ eautoreconf
+}
+
+src_configure() {
+ local -a myconf=(
+ --with-emacs
+ --with-auto-dir="${EPREFIX}/var/lib/${PN}"
+ --with-lispdir="${EPREFIX}${SITELISP}/${PN}"
+ --with-packagelispdir="${EPREFIX}${SITELISP}/${PN}"
+ --with-packagedatadir="${EPREFIX}${SITEETC}/${PN}"
+ --with-texmf-dir="${EPREFIX}${TEXMF}"
+ --disable-build-dir-test
+ $(use_enable preview-latex preview)
+ )
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ VARTEXFONTS="${T}/fonts" emake
+}
+
+src_install() {
+ emake -j1 DESTDIR="${ED}" install
+ elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
+
+ if use preview-latex ; then
+ elisp-site-file-install "${FILESDIR}/60${PN}-gentoo.el"
+ fi
+
+ dodoc ChangeLog* CHANGES FAQ INSTALL PROBLEMS.preview README RELEASE TODO
+}
+
+pkg_postinst() {
+ use preview-latex && texmf-update
+
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ use preview-latex && texmf-update
+
+ elisp-site-regen
+}