summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-emacs/xslide
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-emacs/xslide')
-rw-r--r--app-emacs/xslide/Manifest1
-rw-r--r--app-emacs/xslide/files/50xslide-gentoo.el7
-rw-r--r--app-emacs/xslide/metadata.xml8
-rw-r--r--app-emacs/xslide/xslide-0.2.2.ebuild26
4 files changed, 42 insertions, 0 deletions
diff --git a/app-emacs/xslide/Manifest b/app-emacs/xslide/Manifest
new file mode 100644
index 000000000000..88ba46366898
--- /dev/null
+++ b/app-emacs/xslide/Manifest
@@ -0,0 +1 @@
+DIST xslide-0.2.2.zip 29051 SHA256 dde9884f1584bcb63a8e218542c1a2d619327f4e94847974b6ece31b36c63c42 SHA512 df658464517704289d2695faed02d733adea9f5858310b497d66bf103be5c3e1c3635aa1aa3c93f63c64cd2927b4948e53e7b2593622564f5292c583d6e245a8 WHIRLPOOL 419a49258c9ddf49f5b8870378867f9f1b591efdca685e12881f8c2edb4ddeb4a64817c206fc87df2ffbf7089d08b9a7b3291c8f60c1ad34749de063832ba952
diff --git a/app-emacs/xslide/files/50xslide-gentoo.el b/app-emacs/xslide/files/50xslide-gentoo.el
new file mode 100644
index 000000000000..3ae228472f1b
--- /dev/null
+++ b/app-emacs/xslide/files/50xslide-gentoo.el
@@ -0,0 +1,7 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'xsl-mode "xslide" "Major mode for XSL stylesheets." t)
+;; Turn on font lock when in XSL mode
+(add-hook 'xsl-mode-hook
+ 'turn-on-font-lock)
+(add-to-list 'auto-mode-alist
+ '("\\.fo\\'\\|\\.xsl\\'" . xsl-mode))
diff --git a/app-emacs/xslide/metadata.xml b/app-emacs/xslide/metadata.xml
new file mode 100644
index 000000000000..abe614759038
--- /dev/null
+++ b/app-emacs/xslide/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+<upstream>
+ <remote-id type="sourceforge">xslide</remote-id>
+</upstream>
+</pkgmetadata>
diff --git a/app-emacs/xslide/xslide-0.2.2.ebuild b/app-emacs/xslide/xslide-0.2.2.ebuild
new file mode 100644
index 000000000000..e0f1acd71873
--- /dev/null
+++ b/app-emacs/xslide/xslide-0.2.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit elisp
+
+DESCRIPTION="An Emacs major mode for editing XSL stylesheets and running XSL processes"
+HOMEPAGE="http://www.menteith.com/wiki/xslide"
+SRC_URI="mirror://sourceforge/xslide/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ppc x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+SITEFILE="50${PN}-gentoo.el"
+DOCS="ChangeLog NEWS README.TXT TODO"
+
+src_compile() {
+ emake EMACS=emacs
+}