summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-04-10 18:59:59 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-04-10 22:02:01 +0200
commit28ce7a2727c4b82c2b2ce199962cbe9c6d4cf61f (patch)
treeedaba7178f520232b4ae59502975af9f458afbad /app-emacs/ivy
parenteclass/common-lisp-3: Properly escape recursive install files (diff)
downloadgentoo-28ce7a2727c4b82c2b2ce199962cbe9c6d4cf61f.tar.gz
gentoo-28ce7a2727c4b82c2b2ce199962cbe9c6d4cf61f.tar.bz2
gentoo-28ce7a2727c4b82c2b2ce199962cbe9c6d4cf61f.zip
app-emacs/ivy: new package; add version 0.13.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/ivy')
-rw-r--r--app-emacs/ivy/Manifest1
-rw-r--r--app-emacs/ivy/files/50ivy-gentoo.el3
-rw-r--r--app-emacs/ivy/files/ivy-0.13.4-ivy-test.el-skip.patch39
-rw-r--r--app-emacs/ivy/ivy-0.13.4.ebuild57
-rw-r--r--app-emacs/ivy/metadata.xml15
5 files changed, 115 insertions, 0 deletions
diff --git a/app-emacs/ivy/Manifest b/app-emacs/ivy/Manifest
new file mode 100644
index 000000000000..01a00abc7179
--- /dev/null
+++ b/app-emacs/ivy/Manifest
@@ -0,0 +1 @@
+DIST swiper-0.13.4.tar.gz 245190 BLAKE2B c4da021b92fcedfec39cc60f670c97e4a421b8d4aef8183f50c4872bed835db79884cff113f58cf21dfa7ce33158218aa0cf25d72fc0081dc1c24a3b4376c60e SHA512 bf096a13f675f87af6ea68c974455896b64921ca4d7880c9ccc444aa3cea7c7e04c61be5deb2fd57d0568ff4d86f96ffcf94494b55d84d7a9f647f49b69aec9a
diff --git a/app-emacs/ivy/files/50ivy-gentoo.el b/app-emacs/ivy/files/50ivy-gentoo.el
new file mode 100644
index 000000000000..f9115d44c43a
--- /dev/null
+++ b/app-emacs/ivy/files/50ivy-gentoo.el
@@ -0,0 +1,3 @@
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'ivy-mode "ivy"
+ "Toggle Ivy mode on or off." t)
diff --git a/app-emacs/ivy/files/ivy-0.13.4-ivy-test.el-skip.patch b/app-emacs/ivy/files/ivy-0.13.4-ivy-test.el-skip.patch
new file mode 100644
index 000000000000..e94070cca9c3
--- /dev/null
+++ b/app-emacs/ivy/files/ivy-0.13.4-ivy-test.el-skip.patch
@@ -0,0 +1,39 @@
+diff --git a/ivy-test.el b/ivy-test.el
+index 2062b81..8613337 100644
+--- a/ivy-test.el
++++ b/ivy-test.el
+@@ -2022,6 +1076,7 @@ Since `execute-kbd-macro' doesn't pick up a let-bound `default-directory'.")
+ (should (eq (ivy--sort-function 'c) fn1))))
+
+ (ert-deftest ivy-read-directory-name ()
++ (skip-unless nil)
+ (ivy-mode 1)
+ (unless (file-exists-p ivy-empty)
+ (make-directory ivy-empty))
+@@ -1136,6 +1137,7 @@ Since `execute-kbd-macro' doesn't pick up a let-bound `default-directory'.")
+ :dir "/tmp/"))))
+
+ (ert-deftest ivy-partial-files ()
++ (skip-unless nil)
+ (when (file-exists-p "/tmp/ivy-partial-test")
+ (delete-directory "/tmp/ivy-partial-test" t))
+ (mkdir "/tmp/ivy-partial-test/test1" t)
+@@ -1452,8 +1454,7 @@ a buffer visiting a file."
+
+ (ert-deftest ivy-swiper-wgrep ()
+ ;; `wgrep' requires Emacs 25 or later.
+- (skip-unless (and (>= emacs-major-version 25)
+- (require 'wgrep nil t)))
++ (skip-unless nil)
+ (dolist (search-cmd '(swiper swiper-isearch))
+ (should
+ (string=
+@@ -1585,7 +1586,7 @@ a buffer visiting a file."
+ '("one" "two"))))
+
+ (ert-deftest ivy-avy ()
+- (skip-unless (require 'avy nil t))
++ (skip-unless nil)
+ (require 'ivy-avy)
+ (let ((enable-recursive-minibuffers t)
+ (read-numbers '(ivy-read "test: " (mapcar #'number-to-string
diff --git a/app-emacs/ivy/ivy-0.13.4.ebuild b/app-emacs/ivy/ivy-0.13.4.ebuild
new file mode 100644
index 000000000000..9736ba05dfd7
--- /dev/null
+++ b/app-emacs/ivy/ivy-0.13.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+NEED_EMACS=24.5
+
+inherit elisp
+
+DESCRIPTION="Generic completion mechanism for Emacs"
+HOMEPAGE="https://github.com/abo-abo/swiper/"
+SRC_URI="https://github.com/abo-abo/swiper/archive/${PV}.tar.gz
+ -> swiper-${PV}.tar.gz"
+S="${WORKDIR}"/swiper-${PV}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="sys-apps/texinfo"
+
+DOCS=( CONTRIBUTING.org README.md doc/{ivy-help.org,Changelog.org,ivy.org} )
+ELISP_REMOVE=".dir-locals.el"
+SITEFILE="50${PN}-gentoo.el"
+
+# Some tests are broken (but fixed on master as of 2022--04-10),
+# tests depending on Avy and Wgrep we force to skip.
+PATCHES=( "${FILESDIR}"/${P}-ivy-test.el-skip.patch )
+
+# Main Ivy sources. Swiper, Counsel and Ivy extensions have their own packages.
+IVY_SOURCES=( colir.el ivy{,-overlay,-faces}.el )
+
+src_prepare() {
+ elisp_src_prepare
+
+ # Wipe "elpa.el" to prevent initialization of the "package" library.
+ [[ ! -f elpa.el ]] && die "no \"elpa.el\" found"
+ echo "" > elpa.el || die "failed to wipe \"elpa.el\""
+}
+
+src_compile() {
+ elisp-compile ${IVY_SOURCES[@]}
+
+ emake -C doc ivy.info
+}
+
+src_test() {
+ emake emacs="${EMACS} ${EMACSFLAGS} ${BYTECOMPFLAGS}" test
+}
+
+src_install() {
+ elisp-install ${PN} ${IVY_SOURCES[@]} *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+
+ doinfo doc/ivy.info
+ einstalldocs
+}
diff --git a/app-emacs/ivy/metadata.xml b/app-emacs/ivy/metadata.xml
new file mode 100644
index 000000000000..37581bba4db7
--- /dev/null
+++ b/app-emacs/ivy/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+ </maintainer>
+ <upstream>
+ <changelog>https://raw.githubusercontent.com/abo-abo/swiper/master/doc/Changelog.org</changelog>
+ <bugs-to>https://github.com/abo-abo/swiper/issues/</bugs-to>
+ <remote-id type="github">abo-abo/swiper</remote-id>
+ <doc lang="en">https://oremacs.com/swiper/</doc>
+ </upstream>
+</pkgmetadata>