summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-11-23 14:58:59 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-11-23 16:11:57 +0100
commit4039a51c71935a65ca7f737bd595d9c0e6ee9ab6 (patch)
tree347e50dfcb8e223dc65a8bc53e9cfae44d3b2914 /app-emacs/helm
parentdev-dotnet/nake: bump DOTNET_PKG_COMPAT to 8.0 (diff)
downloadgentoo-4039a51c71935a65ca7f737bd595d9c0e6ee9ab6.tar.gz
gentoo-4039a51c71935a65ca7f737bd595d9c0e6ee9ab6.tar.bz2
gentoo-4039a51c71935a65ca7f737bd595d9c0e6ee9ab6.zip
app-emacs/helm: bump to 3.9.6
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/helm')
-rw-r--r--app-emacs/helm/Manifest1
-rw-r--r--app-emacs/helm/helm-3.9.6.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-emacs/helm/Manifest b/app-emacs/helm/Manifest
index f883f8411833..12365e29703d 100644
--- a/app-emacs/helm/Manifest
+++ b/app-emacs/helm/Manifest
@@ -1 +1,2 @@
DIST helm-3.9.5.tar.gz 2374812 BLAKE2B 6d2428297faa15fff4b07ddc857e89ddc1aa0a6c5a3eb0f96fecff1b01259050c597b43222b169dfbdb86fabe7cbe0094b829bc3dbca42736139a0ec03846176 SHA512 0096580abcf6ac4e9f20cd56a9390b8234c5d08786b13e2d4428568a0412508bb6b0820c88c0a3ceec34495d1c4514166d201986a3b0967ef2a2735d471a94e3
+DIST helm-3.9.6.tar.gz 2377510 BLAKE2B 9a93ce18b8686f7061355da78dec673faaa84b7b2f3259258ef75cf73d2ba6c323ca17771bddf4fe85b710e64503e3e9361c79609e18c42eb2fcc3e0c06f287e SHA512 ebf0fb4dbb2aed5d0e1f312e166862cf5dcd98fa1d2217a9924f9f32869229b8abfbb1ef41c6dc7530a002be62b7592cab9b0f9186135e049bdcb972b614cb6a
diff --git a/app-emacs/helm/helm-3.9.6.ebuild b/app-emacs/helm/helm-3.9.6.ebuild
new file mode 100644
index 000000000000..76671b3b26bc
--- /dev/null
+++ b/app-emacs/helm/helm-3.9.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2019-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp
+
+DESCRIPTION="Emacs incremental completion and selection narrowing framework"
+HOMEPAGE="https://emacs-helm.github.io/helm/
+ https://github.com/emacs-helm/helm/"
+SRC_URI="https://github.com/emacs-helm/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-emacs/async
+ app-emacs/popup
+"
+BDEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.8.8-no-autoload-check.patch )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp-compile *.el
+ elisp-make-autoload-file
+}
+
+src_install() {
+ elisp_src_install
+
+ exeinto /usr/bin/
+ doexe emacs-helm.sh
+}