summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-04-11 15:37:36 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-04-11 15:40:22 +0200
commit7745ad344a4a4e4d369b065f2e700c996c546cb5 (patch)
tree668f07f87f01a03ac2933a62dcfb86f2cdb98eb8 /app-emacs/all-the-icons
parentwww-apps/hugo: add "test-full" USE flag for optional heavy test deps (diff)
downloadgentoo-7745ad344a4a4e4d369b065f2e700c996c546cb5.tar.gz
gentoo-7745ad344a4a4e4d369b065f2e700c996c546cb5.tar.bz2
gentoo-7745ad344a4a4e4d369b065f2e700c996c546cb5.zip
app-emacs/all-the-icons: bump to 5.0.0_p20220325
2022.03.25 snapshot; this version includes https://github.com/domtronn/all-the-icons.el/commit/d10cad0b03cf6f38a8035aacd99de005c961744e and https://github.com/domtronn/all-the-icons.el/commit/49c7f4dfead067ee9756cc65a6c3d18688eb2cc9 which add Gentoo icons Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'app-emacs/all-the-icons')
-rw-r--r--app-emacs/all-the-icons/Manifest1
-rw-r--r--app-emacs/all-the-icons/all-the-icons-5.0.0_p20220325.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-emacs/all-the-icons/Manifest b/app-emacs/all-the-icons/Manifest
index 15ad6fcfb521..3049ed4d9f57 100644
--- a/app-emacs/all-the-icons/Manifest
+++ b/app-emacs/all-the-icons/Manifest
@@ -1 +1,2 @@
DIST all-the-icons-5.0.0.tar.gz 805496 BLAKE2B c5d81d2ff534bb7ab0000c21fb32107f307d96b1bf09b9227be5900e8160b133cfdc7ea4d4b31a982abb55e29bcf35626af91e3bd9ecbfba00b9b5ed85496a7f SHA512 865db191900dbeb207220df8d91220179dfbbb37e983e9e306ba0a4be576055002beb7335de20327736e8be678056699e8385aa37de766fadc11f4688f99471e
+DIST all-the-icons-5.0.0_p20220325.tar.gz 806105 BLAKE2B bc035ee726bf1d2f9839231ddd3bbaaca93b76c30026a3fcef4579f28f7f9677b37fa8b2652e82ae710f23272b56c884cb9454d54d8c2962f20e0fe9cf3c0bdd SHA512 3e45f208b46e7b1b596b6beb41cc11145db49e3e60e7a42593db94000f226e197b30580ba46d490b456f90349e7db2e49027a572b90f32048bcf0e68af9f22bf
diff --git a/app-emacs/all-the-icons/all-the-icons-5.0.0_p20220325.ebuild b/app-emacs/all-the-icons/all-the-icons-5.0.0_p20220325.ebuild
new file mode 100644
index 000000000000..cf28205eb9e6
--- /dev/null
+++ b/app-emacs/all-the-icons/all-the-icons-5.0.0_p20220325.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=65c496d3d1d1298345beb9845840067bffb2ffd8
+NEED_EMACS=24.3
+
+inherit elisp readme.gentoo-r1
+
+DESCRIPTION="Various icon fonts propertized for Emacs"
+HOMEPAGE="https://github.com/domtronn/all-the-icons.el/"
+SRC_URI="https://github.com/domtronn/${PN}.el/archive/${H}.tar.gz
+ -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}.el-${H}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( app-emacs/f )"
+
+DOC_CONTENTS="You may need to install the required fonts by executing
+ the \"all-the-icons-install-fonts\" function."
+DOCS=( README.md logo.png )
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ elisp-compile data/*.el
+}
+
+src_test() {
+ ${EMACS} ${EMACSFLAGS} ${BYTECOMPFLAGS} \
+ -L . -L data -L test -l test/all-the-icons-test.el \
+ -f ert-run-tests-batch-and-exit || die "tests failed"
+}
+
+src_install() {
+ elisp_src_install
+ elisp-install ${PN}/data data/*.el{,c}
+}