summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2024-02-14 13:55:14 +0100
committerUlrich Müller <ulm@gentoo.org>2024-02-14 13:59:48 +0100
commit76480eb12412e13a6f9b105bde10fd7a98b137a6 (patch)
treeb6a148947c104b0eeba120631f0cfe413485c127 /app-editors
parentmedia-libs/oneVPL-intel-gpu: drop 23.4.1 (diff)
downloadgentoo-76480eb12412e13a6f9b105bde10fd7a98b137a6.tar.gz
gentoo-76480eb12412e13a6f9b105bde10fd7a98b137a6.tar.bz2
gentoo-76480eb12412e13a6f9b105bde10fd7a98b137a6.zip
app-editors/e3: Suppress false positive warning for prestripped
Make the build fail if the arch is unknown; update to EAPI 8 for two-argument usev. Closes: https://bugs.gentoo.org/924244 Bug: https://bugs.gentoo.org/924353 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/e3/e3-2.8.2.ebuild10
1 files changed, 7 insertions, 3 deletions
diff --git a/app-editors/e3/e3-2.8.2.ebuild b/app-editors/e3/e3-2.8.2.ebuild
index 1861f7fdb058..02569310fc46 100644
--- a/app-editors/e3/e3-2.8.2.ebuild
+++ b/app-editors/e3/e3-2.8.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit toolchain-funcs
@@ -18,10 +18,14 @@ BDEPEND=">=dev-lang/nasm-2.09.04"
S="${WORKDIR}/${MY_P}"
PATCHES=("${FILESDIR}"/${P}-makefile.patch)
-QA_FLAGS_IGNORED="/usr/bin/e3" #726484
+
+# Suppress false positive QA warnings #726484 #924244
+QA_FLAGS_IGNORED="/usr/bin/e3"
+QA_PRESTRIPPED="/usr/bin/e3"
src_compile() {
- emake -- $(usex amd64 64 32) LD="$(tc-getLD)" DEBUG=true
+ emake -- $(usev amd64 64 || usev x86 32 || die) \
+ LD="$(tc-getLD)" DEBUG=true
}
src_install() {