summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor <coyote@bks.tv>2018-01-01 22:19:10 +0300
committerMikle Kolyada <zlogene@gentoo.org>2018-01-04 22:06:54 +0300
commitaf2ab4a3e7880cb7a5605080e5c17a136d889765 (patch)
treeb1576a3985971e01b81e6184d5b47b0742b01600 /app-editors/qhexedit2/files
parentx11-plugins/wmdrawer: add missing x11-libs/gdk-pixbuf:2 dep (diff)
downloadgentoo-af2ab4a3e7880cb7a5605080e5c17a136d889765.tar.gz
gentoo-af2ab4a3e7880cb7a5605080e5c17a136d889765.tar.bz2
gentoo-af2ab4a3e7880cb7a5605080e5c17a136d889765.zip
app-editors/qhexedit2: new package
QHexEdit is a hex editor widget written in C++ for the Qt5 framework. Used by ponyprog2000. Package-Manager: Portage-2.3.13, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/6728
Diffstat (limited to 'app-editors/qhexedit2/files')
-rw-r--r--app-editors/qhexedit2/files/qhexedit2-0.8.4-fixtest.patch12
-rw-r--r--app-editors/qhexedit2/files/qhexedit2-0.8.4-setup.py.patch11
2 files changed, 23 insertions, 0 deletions
diff --git a/app-editors/qhexedit2/files/qhexedit2-0.8.4-fixtest.patch b/app-editors/qhexedit2/files/qhexedit2-0.8.4-fixtest.patch
new file mode 100644
index 000000000000..339ef99477ee
--- /dev/null
+++ b/app-editors/qhexedit2/files/qhexedit2-0.8.4-fixtest.patch
@@ -0,0 +1,12 @@
+--- qhexedit2-0.8.4/test/testchunks.cpp- 2017-01-17 02:32:54.000000000 +0300
++++ qhexedit2-0.8.4/test/testchunks.cpp 2018-01-03 21:34:24.988555308 +0300
+@@ -1,8 +1,7 @@
+ #include "testchunks.h"
+ #include <cstdlib>
+
+-
+-TestChunks::TestChunks(QTextStream &log, QString tName, int size, bool random, int saveFile)
++TestChunks::TestChunks(QTextStream &log, QString tName, int size, bool random, int saveFile): _chunks(nullptr)
+ {
+ char hex[] = "0123456789abcdef";
+ srand(0);
diff --git a/app-editors/qhexedit2/files/qhexedit2-0.8.4-setup.py.patch b/app-editors/qhexedit2/files/qhexedit2-0.8.4-setup.py.patch
new file mode 100644
index 000000000000..83d9183fcdbe
--- /dev/null
+++ b/app-editors/qhexedit2/files/qhexedit2-0.8.4-setup.py.patch
@@ -0,0 +1,11 @@
+--- qhexedit2-0.8.4/setup.py- 2018-01-02 19:40:57.542961661 +0300
++++ qhexedit2-0.8.4/setup.py 2017-01-17 02:32:54.000000000 +0300
+@@ -98,7 +98,7 @@
+ lib + ".framework", "Headers")]
+ else:
+ if PyQt_Version == 'PyQt5':
+- for qt_inc_dir in ('/usr/include/qt', '/usr/include/x86_64-linux-gnu/qt5'):
++ for qt_inc_dir in ('/usr/include/qt', '/usr/include/qt5'):
+ include_dirs.append(qt_inc_dir)
+ include_dirs += [os.path.join(qt_inc_dir, lib) for lib in qt_libs]
+ libraries = ["Qt5" + lib[2:] for lib in qt_libs]