summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-10-22 23:39:32 +0100
committerSam James <sam@gentoo.org>2023-10-23 00:02:56 +0100
commitf6b99a1d00b186e1902b3c10abfd27de9b602535 (patch)
treeead950e73b01f8a8f90519473d13a8c96fa685da /app-editors/micro
parentsys-kernel/git-sources: add 6.6_rc7 (diff)
downloadgentoo-f6b99a1d00b186e1902b3c10abfd27de9b602535.tar.gz
gentoo-f6b99a1d00b186e1902b3c10abfd27de9b602535.tar.bz2
gentoo-f6b99a1d00b186e1902b3c10abfd27de9b602535.zip
app-editors/micro: add 2.0.13
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-editors/micro')
-rw-r--r--app-editors/micro/Manifest2
-rw-r--r--app-editors/micro/micro-2.0.13.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/app-editors/micro/Manifest b/app-editors/micro/Manifest
index 4caced452bae..014d0f60cc01 100644
--- a/app-editors/micro/Manifest
+++ b/app-editors/micro/Manifest
@@ -2,3 +2,5 @@ DIST micro-2.0.11-deps.tar.xz 19390200 BLAKE2B 3f4e3a60395854e1dcba0ed69c7f6b95d
DIST micro-2.0.11.tar.gz 549261 BLAKE2B 30c21d7747870a9a85a8fb552ec9035af5c42232f4d2ee0744c24671e78ee22ff5eea803fbc19fac704b49644df0597538950b735f955eecc921e681c0ad924c SHA512 3aa3dd10baaec9fa73b5c673c3d29eb8b4d04b468e36866118bcfc70dd638c50e56d51fc6085dcc7441a2ce0d9bbf742c37fd26a7e2b92d8b20844c8a7b53487
DIST micro-2.0.12-deps.tar.xz 27563572 BLAKE2B 416548c7b2effa88f80aeb00e15645ace642859af9b3992ec8bc702237a2a17440d34a0ccdad4079933e38fec5ae4d06749a094d211d9fc9f7a11cca9b098a29 SHA512 157f655dfab205e918367c1ea9de849c3c90671bbdf50e8c869e239350f923c62540695839e114e44d6740c06bb0855d5aa139876fe38fe87d24e3162029daef
DIST micro-2.0.12.tar.gz 562941 BLAKE2B b360560cb0e4b27739e4efc880c66e4e934e3b6515062fb853f29ca9ee21e62edfac8ab0d554bff0062089c20ef2ab11b7d28180b851774f25327c6da58793e2 SHA512 a03fe2b91914c423f0195e9a7c7d35c3c6a38ec2ba65ca8dd8719da38806f2bc5a7b10efb73f9a2ee884bdf3f2a71a04bc3404a7a811b4fb329ffdf41336b78a
+DIST micro-2.0.13-deps.tar.xz 27532560 BLAKE2B ed994b56a73861db0eaff9c394df5a5b6c0900328c068ab9b6e4cace2ffd36082e455da22f02cd43d41386fe587b51189fb01dd04bae821aeccdefb679ec9a6a SHA512 23959b46e7602091f61ddb01d25188956b558585674dc8a782e191dd52d4912132bea860530d1a25e97015d242a2a28a9cf4c5098974e85dcf78c3dc4757734a
+DIST micro-2.0.13.tar.gz 563438 BLAKE2B f3d1876e9eff95fa59d52cc324c4682609c80fff4be8b37fdc701c452df54f35fe57502b0dac7d8aa07f7d02496c3c7ed8f06bba515466a631a39b1816eceba3 SHA512 b4b1dd3b03c906ee5c0bf9d0b576efea2a527fcdb0fe40338c78515fd5f6a4eb22bd9541567bb5956c4087e749775a1e8c33a73d185f7a6b00ba91e405d6a117
diff --git a/app-editors/micro/micro-2.0.13.ebuild b/app-editors/micro/micro-2.0.13.ebuild
new file mode 100644
index 000000000000..5ccf1af373bf
--- /dev/null
+++ b/app-editors/micro/micro-2.0.13.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module optfeature desktop xdg
+
+DESCRIPTION="Modern and intuitive terminal-based text editor"
+HOMEPAGE="https://github.com/zyedidia/micro"
+SRC_URI="https://github.com/zyedidia/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="MIT Apache-2.0 BSD MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+BDEPEND="dev-vcs/git"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0.12-no-strip.patch
+)
+
+src_compile() {
+ # We build/install this way for bug #915628 (highlighting)
+ emake VERSION=${PV} build
+}
+
+src_install() {
+ dodir /usr/bin
+ emake GOBIN="${ED}"/usr/bin install
+ doman ./assets/packaging/micro.1
+ domenu assets/packaging/micro.desktop
+ einstalldocs
+}
+
+pkg_postinst() {
+ # Update desktop file mime cache
+ xdg_pkg_postinst
+
+ optfeature_header "Clipboard support with display servers:"
+ optfeature "Xorg" x11-misc/xsel x11-misc/xclip
+ optfeature "Wayland" gui-apps/wl-clipboard
+}