summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2024-09-27 09:02:26 +0200
committerUlrich Müller <ulm@gentoo.org>2024-09-27 09:15:44 +0200
commit20abbf2ecbe03997b8cd2aaf231fac8a883c5d9d (patch)
tree0d057f8cad3f41f8b9983db903a8be57844979cf /app-editors/emacs/emacs-30.0.9999-r1.ebuild
parentdev-java/cdi-api: fix installation for USE=source #940305 (diff)
downloadgentoo-20abbf2ecbe03997b8cd2aaf231fac8a883c5d9d.tar.gz
gentoo-20abbf2ecbe03997b8cd2aaf231fac8a883c5d9d.tar.bz2
gentoo-20abbf2ecbe03997b8cd2aaf231fac8a883c5d9d.zip
app-editors/emacs: Drop xwidgets flag
WebKitGTK upstream dropped support for off-screen rendering in webkit2gtk version 2.41.92 and newer. This breaks xwidget support and causes Emacs to crash. See https://debbugs.gnu.org/66068#47 for a more detailed explanation. Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'app-editors/emacs/emacs-30.0.9999-r1.ebuild')
-rw-r--r--app-editors/emacs/emacs-30.0.9999-r1.ebuild17
1 files changed, 4 insertions, 13 deletions
diff --git a/app-editors/emacs/emacs-30.0.9999-r1.ebuild b/app-editors/emacs/emacs-30.0.9999-r1.ebuild
index 7d7e32e39e10..b151a0271ab1 100644
--- a/app-editors/emacs/emacs-30.0.9999-r1.ebuild
+++ b/app-editors/emacs/emacs-30.0.9999-r1.ebuild
@@ -40,7 +40,7 @@ DESCRIPTION="The extensible, customizable, self-documenting real-time display ed
HOMEPAGE="https://www.gnu.org/software/emacs/"
LICENSE="GPL-3+ FDL-1.3+ BSD HPND MIT W3C unicode PSF-2"
-IUSE="acl alsa aqua athena cairo dbus dynamic-loading games gfile gif +gmp gpm gsettings gtk gui gzip-el harfbuzz imagemagick +inotify jit jpeg kerberos lcms libxml2 livecd m17n-lib mailutils motif png selinux sound source sqlite ssl svg systemd +threads tiff toolkit-scroll-bars tree-sitter valgrind webp wide-int +X xattr Xaw3d xft +xpm xwidgets zlib"
+IUSE="acl alsa aqua athena cairo dbus dynamic-loading games gfile gif +gmp gpm gsettings gtk gui gzip-el harfbuzz imagemagick +inotify jit jpeg kerberos lcms libxml2 livecd m17n-lib mailutils motif png selinux sound source sqlite ssl svg systemd +threads tiff toolkit-scroll-bars tree-sitter valgrind webp wide-int +X xattr Xaw3d xft +xpm zlib"
X_DEPEND="x11-libs/libICE
x11-libs/libSM
@@ -67,13 +67,7 @@ X_DEPEND="x11-libs/libICE
>=dev-libs/m17n-lib-1.5.1
)
)
- gtk? (
- x11-libs/gtk+:3
- xwidgets? (
- net-libs/webkit-gtk:4.1=
- x11-libs/libXcomposite
- )
- )
+ gtk? ( x11-libs/gtk+:3 )
!gtk? (
motif? (
>=x11-libs/motif-2.3:0
@@ -144,7 +138,6 @@ RDEPEND="app-emacs/emacs-common[games?,gui(-)?]
>=dev-libs/libotf-0.9.4
>=dev-libs/m17n-lib-1.5.1
)
- xwidgets? ( net-libs/webkit-gtk:4.1= )
) )
!gtk? ( ${X_DEPEND} )
X? ( ${X_DEPEND} )
@@ -268,11 +261,11 @@ src_configure() {
myconf+=" --with-pgtk --without-x --without-ns"
myconf+=" --with-toolkit-scroll-bars" #836392
myconf+=" --without-gconf"
+ myconf+=" --without-xwidgets"
myconf+=" $(use_with gsettings)"
myconf+=" $(use_with harfbuzz)"
myconf+=" $(use_with m17n-lib libotf)"
myconf+=" $(use_with m17n-lib m17n-flt)"
- myconf+=" $(use_with xwidgets)"
else
# X11
myconf+=" --with-x --without-pgtk --without-ns"
@@ -310,7 +303,7 @@ src_configure() {
recommended that you compile Emacs with the Athena/Lucid or the
Motif toolkit instead.
EOF
- myconf+=" --with-x-toolkit=gtk3 $(use_with xwidgets)"
+ myconf+=" --with-x-toolkit=gtk3 --without-xwidgets"
for f in motif Xaw3d athena; do
use ${f} && ewarn \
"USE flag \"${f}\" has no effect if \"gtk\" is set."
@@ -329,8 +322,6 @@ src_configure() {
einfo "Configuring to build with no toolkit"
myconf+=" --with-x-toolkit=no"
fi
- ! use gtk && use xwidgets && ewarn \
- "USE flag \"xwidgets\" has no effect if \"gtk\" is not set."
fi
if use gui; then