summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-07 08:56:35 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-07 08:56:35 +0200
commit638b582cfc90c4eea390c41c3814377127f44950 (patch)
tree5d2e2004e3a9dca2d1f0085c0ec65b1a3482a126 /app-doc/python-docs
parentapp-doc/python-docs: Bump to 3.11.10 (diff)
downloadgentoo-638b582cfc90c4eea390c41c3814377127f44950.tar.gz
gentoo-638b582cfc90c4eea390c41c3814377127f44950.tar.bz2
gentoo-638b582cfc90c4eea390c41c3814377127f44950.zip
app-doc/python-docs: Bump to 3.10.15
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-doc/python-docs')
-rw-r--r--app-doc/python-docs/Manifest1
-rw-r--r--app-doc/python-docs/python-docs-3.10.15.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/app-doc/python-docs/Manifest b/app-doc/python-docs/Manifest
index 7e782fb9b269..720704ab2a19 100644
--- a/app-doc/python-docs/Manifest
+++ b/app-doc/python-docs/Manifest
@@ -1,5 +1,6 @@
DIST python-2.7.18-docs-html.tar.bz2 4634932 BLAKE2B c48e2dede15d8186231acf65709641e0844c42e924262d6ee21a55e515aaf4d023bf394681bab780ab83998de9f409685e2d5870506810432145acc6422eff9d SHA512 db39390577ec86f13c9b6b57c01cba36fe9fd89092a773dc94f1a6a19d912759d097c4d80e765d3657b572abc731c1da9e7b4cd4c38065cd444606b906744abe
DIST python-3.10.14-docs-html.tar.bz2 7441459 BLAKE2B 484508fc2610fdffe6bd7370afe27a0a4d7672fd4d528a726ec5b03ca7084e88d057326ccb3e41d79b6ab105211314d3b3e4c11acab40d4ce8dab725b80be5d7 SHA512 4232cca2c31a87362d3c0bde27f029eb4f475be0eab4eeeaeffa70825f2d40c91d80e88feb44408c2014ee5e012554442f0c1d394f110b9e49209e7534cce600
+DIST python-3.10.15-docs-html.tar.bz2 7452520 BLAKE2B e9003e2a839bc934d3ba5903e1b730239e48d06686b5472660d49c51333b77ec1b0c3c48c307007e4f5d27901764d29203de475e60e97d8d8004e0b2436d168d SHA512 7056b2e9d3672b79aee26f994fd1e5168860452ec783f37cdc604dc25d3df297a9c43bda43add03a36aec85dbd1875d0c9b8eaec0fd75b809fd3811a977b69a0
DIST python-3.11.10-docs-html.tar.bz2 7988162 BLAKE2B bc0d47ca235c8c14c4f62b554578068bf3e8460211e358cec586511be35b0aa2011075ace0602385dca2b4c2667d6bd3cb8ce4e6e6be1ed52d84b877cf3a7f6a SHA512 a14e18d3641d4379144ead7341536c781a94e9f15c9b53b2647a7c7c4cd15211963564fb2519e756b79db9234f555ede2442a678d6b4f27de6f7fb0b2993c266
DIST python-3.11.9-docs-html.tar.bz2 7996912 BLAKE2B 5140cc58986ff062e4425e4635fa1e92b089b805d47f7f9f8c92cd96474101e63125116ee000817a29e1878417577e7f0a279cff88bd74a76bea6c8428b21807 SHA512 d60c8811bb1099b56737b6807552f2f503d6c4cb0fe7adb3ba584796bed1da64ec514865580c07bcafdfd906118987d6ea0433eb2fb19a2a68f30880c28f4889
DIST python-3.12.3-docs-html.tar.bz2 8304437 BLAKE2B 51e60030941ea26c9531357bfdd5746cf4ff03d59fbca705d146188c612d3e77cafeabe49ecc96b3531ced9cd88ef74a2ad87fdd064fd4c3d836065132e20c98 SHA512 2b4cc99d1e22a77959e82c910303d4247efa6579060cb3c69b0d9dd1b868dc1637eb1443552fd89d5314c6d7d01c579e2113539491ebc0fa5ec4a6f2ab0b4d98
diff --git a/app-doc/python-docs/python-docs-3.10.15.ebuild b/app-doc/python-docs/python-docs-3.10.15.ebuild
new file mode 100644
index 000000000000..8483ad559ab4
--- /dev/null
+++ b/app-doc/python-docs/python-docs-3.10.15.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="HTML documentation for Python"
+HOMEPAGE="https://www.python.org/doc/"
+SRC_URI="https://www.python.org/ftp/python/doc/${PV}/python-${PV}-docs-html.tar.bz2"
+S="${WORKDIR}/python-${PV}-docs-html"
+
+LICENSE="PSF-2"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+src_install() {
+ rm -r _sources || die
+ docinto html
+ dodoc -r .
+
+ newenvd - 60python-docs-${SLOT} <<-EOF
+ PYTHONDOCS_${SLOT//./_}="${EPREFIX}/usr/share/doc/${PF}/html/library"
+ EOF
+}