summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2020-08-15 21:59:12 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2020-08-15 21:59:26 -0700
commita16c3c3ba794eb16af95abb92005a84f971997e8 (patch)
tree902dd44b5531df32c20a2d4e73c4558455767aef /app-crypt
parentdev-libs/libxml2: add upstream patch for consumers (diff)
downloadgentoo-a16c3c3ba794eb16af95abb92005a84f971997e8.tar.gz
gentoo-a16c3c3ba794eb16af95abb92005a84f971997e8.tar.bz2
gentoo-a16c3c3ba794eb16af95abb92005a84f971997e8.zip
app-crypt/acmebot: bump
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/acmebot/Manifest1
-rw-r--r--app-crypt/acmebot/acmebot-2.7.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/app-crypt/acmebot/Manifest b/app-crypt/acmebot/Manifest
index 4b55640b4b68..c2f4e840601d 100644
--- a/app-crypt/acmebot/Manifest
+++ b/app-crypt/acmebot/Manifest
@@ -1 +1,2 @@
DIST acmebot-2.3.0.tar.gz 64841 BLAKE2B 92bfb9a58722b9955fe908e2fcb1a3ee593bf87e3fdf3dc9564bcbe291b13c553ad426673c337a59344287da64c4ee5cffc734f8dfb60447f96d6234814f0167 SHA512 3951cc7138eb0b83bd802a2e0a221fa985209ba276028606d887b7d2eff84c35db034f4a3d8a6836b3ac149c6dbfa27b1ea47e864f549f8d88b758b40407c4f4
+DIST acmebot-2.7.0.tar.gz 76385 BLAKE2B 28b0fd81735e2dbff493dbcfe0194d62dea8d233866dcb235bb0efac562d2f3884f53226f979e8cd6050078f59b0b1e6d20d2eeea6d762363526686ef8c5ead1 SHA512 1b8fa21c2dc60a940e2fa13d5d599025088644862c985749d72f4f16ebd4ad48970b7fcf656fb34cf63d3c2ff2cbb157d7446c17a7f9da3cffd8611e499c400e
diff --git a/app-crypt/acmebot/acmebot-2.7.0.ebuild b/app-crypt/acmebot/acmebot-2.7.0.ebuild
new file mode 100644
index 000000000000..e6b7da902b1b
--- /dev/null
+++ b/app-crypt/acmebot/acmebot-2.7.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python3_{7,8})
+EGIT_REPO_URI="https://github.com/plinss/${PN}.git"
+[[ $PV == 9999 ]] && _scm=git-r3
+
+inherit ${_scm} python-single-r1
+
+DESCRIPTION="Certificate manager bot using ACME protocol"
+HOMEPAGE="https://github.com/plinss/acmebot"
+if [[ $PV != 9999 ]]; then
+ SRC_URI="https://github.com/plinss/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+[[ $PV != 9999 ]] && KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ >=dev-python/appdirs-1.4.3[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pyparsing-2.2.0[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/packaging-16.8[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pyopenssl-17.5.0[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pydns-3.1.0:3[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/cryptography-2.1.4[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/asn1crypto-0.24.0[${PYTHON_MULTI_USEDEP}]
+ >=app-crypt/acme-0.25.1[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pyyaml-3.1[${PYTHON_MULTI_USEDEP}]
+ ')
+ "
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+src_prepare() {
+ default
+ python_fix_shebang .
+}
+
+src_configure() {
+ :
+}
+src_compile() {
+ :
+}
+
+src_install() {
+ python_doscript acmebot
+ insinto /etc/logrotate.d
+ doins logrotate.d/acmebot
+ insinto /etc/acmebot
+ doins acmebot.example.json
+ dodoc README.rst
+}