summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2024-02-09 22:40:46 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2024-02-09 22:40:46 -0600
commit90e806c7522309bcb170bce5fe71823b1be6db52 (patch)
tree9bcc5e33ede6c7ef5dca9f50cfe166e8f4358f20 /app-crypt
parentapp-crypt/certbot: add 2.9.0 (diff)
downloadgentoo-90e806c7522309bcb170bce5fe71823b1be6db52.tar.gz
gentoo-90e806c7522309bcb170bce5fe71823b1be6db52.tar.bz2
gentoo-90e806c7522309bcb170bce5fe71823b1be6db52.zip
app-crypt/certbot-apache: add 2.9.0
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/certbot-apache/Manifest1
-rw-r--r--app-crypt/certbot-apache/certbot-apache-2.9.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-crypt/certbot-apache/Manifest b/app-crypt/certbot-apache/Manifest
index 91edfdbab5f9..2aa6fc0bd107 100644
--- a/app-crypt/certbot-apache/Manifest
+++ b/app-crypt/certbot-apache/Manifest
@@ -1 +1,2 @@
DIST certbot-2.8.0.gh.tar.gz 1344483 BLAKE2B f9957367ae65f69ab43a83993b29da4d28c0d01bd7a89ebefcbfb82915c26167b7443d08f6ee4d28e029f5a58736dee01700a30261aaa1dc0290273868da08e9 SHA512 2fbaf5349e7ef0dcb054c3b22d63007c588cbdc0d23d484a56e62ad38d21c91b838887e6e94cf9c0045a4382567c342288a796c81307deba84a246f5cc3bc5d6
+DIST certbot-2.9.0.gh.tar.gz 1346993 BLAKE2B cf7fb4676dc31442abe11ef50d18073480a46f4ab19cc328da599b1372509af683b4c6010b46f31bce5703949e88b4702d404bd8582a1361caad43ec8f02cb94 SHA512 27c15ce8e4450f432fbc271cd847d27c7f1bce552cc6e5f2a91f1fbfc09ebe331b54bab17639b86c19605de059767015665c26e872c3b0699edb1c85392a0546
diff --git a/app-crypt/certbot-apache/certbot-apache-2.9.0.ebuild b/app-crypt/certbot-apache/certbot-apache-2.9.0.ebuild
new file mode 100644
index 000000000000..07c1b3fa631b
--- /dev/null
+++ b/app-crypt/certbot-apache/certbot-apache-2.9.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+PARENT_PN="${PN%-apache}"
+PARENT_P="${PARENT_PN}-${PV}"
+
+if [[ "${PV}" == *9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
+else
+ SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${PARENT_P}.gh.tar.gz
+ "
+ # Only for amd64, arm64 and x86 because of dev-python/python-augeas
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DESCRIPTION="Apache plugin for Certbot (Let’s Encrypt client)"
+HOMEPAGE="
+ https://github.com/certbot/certbot
+ https://letsencrypt.org/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+S="${WORKDIR}/${PARENT_P}/${PN}"
+
+BDEPEND="
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ dev-python/python-augeas[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest