summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-crypt/ssh-multiadd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-crypt/ssh-multiadd')
-rw-r--r--app-crypt/ssh-multiadd/Manifest1
-rw-r--r--app-crypt/ssh-multiadd/metadata.xml8
-rw-r--r--app-crypt/ssh-multiadd/ssh-multiadd-1.3.2-r1.ebuild35
-rw-r--r--app-crypt/ssh-multiadd/ssh-multiadd-1.3.2.ebuild40
4 files changed, 84 insertions, 0 deletions
diff --git a/app-crypt/ssh-multiadd/Manifest b/app-crypt/ssh-multiadd/Manifest
new file mode 100644
index 000000000000..91fb05466148
--- /dev/null
+++ b/app-crypt/ssh-multiadd/Manifest
@@ -0,0 +1 @@
+DIST ssh-multiadd-1.3.2.tar.gz 14035 SHA256 5526a9682b5d5e5051f91cd64a3e472bc6311939ee412725bf94eabb8f2f94c8 SHA512 fd4f26bfa5e2f654fc650470353901c6f418685f971ec4b5834afd0136e77469523c49b7cacb1b9716ff6c8cbbe810a057b214927f0325524170db84aebacbb3 WHIRLPOOL 871af4cb49282fbf22c547b99a9c14d035fd8766ba29899add5e2522d1a648df3e9705837b99a5cbfbe87ad0f363fab262905fe104353123171bfcccbb5be52f
diff --git a/app-crypt/ssh-multiadd/metadata.xml b/app-crypt/ssh-multiadd/metadata.xml
new file mode 100644
index 000000000000..1828ec211c31
--- /dev/null
+++ b/app-crypt/ssh-multiadd/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>idella4@gentoo.org</email>
+ <name>Ian Delaney</name>
+</maintainer>
+</pkgmetadata>
diff --git a/app-crypt/ssh-multiadd/ssh-multiadd-1.3.2-r1.ebuild b/app-crypt/ssh-multiadd/ssh-multiadd-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..97cc8cc33990
--- /dev/null
+++ b/app-crypt/ssh-multiadd/ssh-multiadd-1.3.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Adds multiple ssh keys to the ssh authentication agent"
+HOMEPAGE="http://code.fluffytapeworm.com/projects"
+SRC_URI="http://code.fluffytapeworm.com/projects/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="X"
+
+DEPEND=""
+RDEPEND="X? ( >=net-misc/x11-ssh-askpass-1.2.2 )"
+
+src_prepare() {
+ python_fix_shebang .
+}
+
+src_compile(){
+ :
+}
+
+src_install() {
+ dobin ssh-multiadd
+ doman ssh-multiadd.1
+ dodoc Changelog README todo
+}
diff --git a/app-crypt/ssh-multiadd/ssh-multiadd-1.3.2.ebuild b/app-crypt/ssh-multiadd/ssh-multiadd-1.3.2.ebuild
new file mode 100644
index 000000000000..40de0e6832b6
--- /dev/null
+++ b/app-crypt/ssh-multiadd/ssh-multiadd-1.3.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+PYTHON_DEPEND="2"
+
+inherit python
+
+DESCRIPTION="Adds multiple ssh keys to the ssh authentication agent"
+HOMEPAGE="http://code.fluffytapeworm.com/projects"
+SRC_URI="http://code.fluffytapeworm.com/projects/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="X"
+
+DEPEND=""
+RDEPEND="X? ( >=net-misc/x11-ssh-askpass-1.2.2 )"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+}
+
+src_compile(){
+ :
+}
+
+src_install() {
+ dobin ssh-multiadd
+ doman ssh-multiadd.1
+ dodoc Changelog README todo
+}