summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno <hanno@gentoo.org>2018-12-23 17:07:07 +0100
committerHanno <hanno@gentoo.org>2018-12-23 17:07:07 +0100
commit4aad46ccc01e09efe8d6c20a50c9af3934d47f3b (patch)
tree6d7296e772c41bfc592ea49c1363a4832c229df7 /app-crypt/osslsigncode
parentprofiles: Add osslsigncode-2.0 (openssl 1.1 only) to package.mask (diff)
downloadgentoo-4aad46ccc01e09efe8d6c20a50c9af3934d47f3b.tar.gz
gentoo-4aad46ccc01e09efe8d6c20a50c9af3934d47f3b.tar.bz2
gentoo-4aad46ccc01e09efe8d6c20a50c9af3934d47f3b.zip
app-crypt/osslsigncode: Version bump.
This is a fork that only supports the new OpenSSL api. Masked for now, should be unmasked together with OpenSSL 1.1.1. Closes: https://bugs.gentoo.org/672664 Signed-off-by: Hanno Boeck <hanno@gentoo.org> Package-Manager: Portage-2.3.52, Repoman-2.3.12
Diffstat (limited to 'app-crypt/osslsigncode')
-rw-r--r--app-crypt/osslsigncode/Manifest1
-rw-r--r--app-crypt/osslsigncode/osslsigncode-2.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-crypt/osslsigncode/Manifest b/app-crypt/osslsigncode/Manifest
index f2682eea0a82..4e6c832a8d5a 100644
--- a/app-crypt/osslsigncode/Manifest
+++ b/app-crypt/osslsigncode/Manifest
@@ -1,2 +1,3 @@
DIST osslsigncode-1.4.tar.gz 96512 BLAKE2B 8325153d16b7ad5d0701daf3d5d446bef498aaf45b88a78d5472d86c0899a73bff2350c224f9f3e35475d5dd72792fe24328f4710d25984ae23c5f83c6fef967 SHA512 89f82b5cbab5952b7bb0b1a3ea230db0c38d171924e5150e9cd157158e52d312cc10093ac719265d03a097f995bd3a438fe874c50263659859c625482ef0239f
DIST osslsigncode-1.7.1.tar.gz 127631 BLAKE2B f0ced06a33968f03558e189fc9ed2340dba2cdfe823422c760d62476446646f198aed1a95f99734f80e7ec71d23cd286a23e68953f7e432a9a6ff048c76cae63 SHA512 cc5a7e0c5baa2a98db93f1d2cc9d86e732e2a8a55fc20bf8e6aa67e2120af37c6be857dfe4b8eb8c82fd40604dbb3c845190b59c7e6b4147f06b710a256b877f
+DIST osslsigncode-2.0.tar.gz 57951 BLAKE2B 67057c07bb667a546e3a8abc49e8a20a0ef42ae77edacd2e88486a4357e8e8e789307e1c2abd2e13d18401621ba5607bb42af46ed8451546a26bb6855a07e652 SHA512 aec7b101afd96925fbd70ac67a6752997f0dab3987151c0658e5f011d8a6be6f53518d7a4aba6dff696c722a1e669100143a87d07c3f59364cd62693e9f3e4e5
diff --git a/app-crypt/osslsigncode/osslsigncode-2.0.ebuild b/app-crypt/osslsigncode/osslsigncode-2.0.ebuild
new file mode 100644
index 000000000000..f88975d1bc93
--- /dev/null
+++ b/app-crypt/osslsigncode/osslsigncode-2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools
+
+DESCRIPTION="Platform-independent tool for Authenticode signing of EXE/CAB files"
+HOMEPAGE="https://github.com/mtrojnar/osslsigncode"
+SRC_URI="https://github.com/mtrojnar/osslsigncode/archive/2.0.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="curl libressl"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ curl? ( net-misc/curl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ eautoreconf
+ eapply_user
+}
+
+src_configure() {
+ econf $(use_with curl)
+}