summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-02-10 15:03:00 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-02-10 15:03:57 +0300
commit4e76ce37a2778be9b996e0c1add5669a322eee46 (patch)
tree2fb1c5c77679957a670c260b883151cccd3ceaaf /app-crypt/easy-rsa/easy-rsa-3.0.6.ebuild
parentprofiles: powerpc: mv dev-python/matplotlib[qt5,test] to stable-mask (diff)
downloadgentoo-4e76ce37a2778be9b996e0c1add5669a322eee46.tar.gz
gentoo-4e76ce37a2778be9b996e0c1add5669a322eee46.tar.bz2
gentoo-4e76ce37a2778be9b996e0c1add5669a322eee46.zip
app-crypt/easy-rsa: Version bump (v3.0.6)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'app-crypt/easy-rsa/easy-rsa-3.0.6.ebuild')
-rw-r--r--app-crypt/easy-rsa/easy-rsa-3.0.6.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-crypt/easy-rsa/easy-rsa-3.0.6.ebuild b/app-crypt/easy-rsa/easy-rsa-3.0.6.ebuild
new file mode 100644
index 000000000000..f827f0cc84ee
--- /dev/null
+++ b/app-crypt/easy-rsa/easy-rsa-3.0.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Small RSA key management package, based on OpenSSL"
+HOMEPAGE="https://openvpn.net/"
+SRC_URI="https://github.com/OpenVPN/easy-rsa/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="libressl"
+
+DEPEND="!libressl? ( >=dev-libs/openssl-0.9.6:0 )
+ libressl? ( dev-libs/libressl )"
+RDEPEND="${DEPEND}
+ !<net-vpn/openvpn-2.3"
+
+src_install() {
+ exeinto /usr/share/easy-rsa
+ doexe easyrsa3/easyrsa
+ insinto /usr/share/easy-rsa
+ doins -r easyrsa3/{vars.example,openssl-easyrsa.cnf,x509-types}
+ dodoc README.quickstart.md ChangeLog
+ dodoc -r doc
+ doenvd "${FILESDIR}/65easy-rsa" # config-protect easy-rsa
+}