summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-06-19 11:20:16 +0200
committerPacho Ramos <pacho@gentoo.org>2024-06-19 11:20:16 +0200
commit92e8e36f872d3c54abf98b7eef73eae2cc0a30e7 (patch)
tree595ba1c0b895dd2fafd76c6cfdd6aef70e3002ab /app-containers
parentapp-admin/yadm: enable py3.12 (diff)
downloadgentoo-92e8e36f872d3c54abf98b7eef73eae2cc0a30e7.tar.gz
gentoo-92e8e36f872d3c54abf98b7eef73eae2cc0a30e7.tar.bz2
gentoo-92e8e36f872d3c54abf98b7eef73eae2cc0a30e7.zip
app-containers/sen: add 0.7.0
Closes: https://bugs.gentoo.org/675534 Closes: https://bugs.gentoo.org/684070 Closes: https://bugs.gentoo.org/800167 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/sen/Manifest1
-rw-r--r--app-containers/sen/sen-0.7.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/app-containers/sen/Manifest b/app-containers/sen/Manifest
index f610c5c57e56..5cabc2c10433 100644
--- a/app-containers/sen/Manifest
+++ b/app-containers/sen/Manifest
@@ -1 +1,2 @@
DIST sen-0.6.1_p20200905.tar.gz 1913978 BLAKE2B 189bff583770265de29ca3e54cad1283051c05eccab4fc98160801e50b31376188c52e49b43972292fe231b376ba42879fb34d7b1ae70c2246d676a6e25f670b SHA512 cd1899c1b4c5c7cf7f1f2f5e557bd609a7d7619dbc3fc6457f5ef5ce5c9ab43d92a6fbfa228c43d543d4f46c7928d74dbed9ab8346cabc772c8e7c63a7c07bfe
+DIST sen-0.7.0.tar.gz 1930302 BLAKE2B b17eeb080d2873485e81e90b7bee81f4930ace05b5d10a259a062b1dc818659d61a45d8bf01df95c33514060cce84f5c09f82066400afe11e4797fffa4303b6b SHA512 fc350eaf6694df2ff2378e24e06a07247a5c5bc060e09c4bb5478deca781d4f4fc593927dff14a1e7c7779eabb897fb6170183daee48a4e6b03bcfef975521b0
diff --git a/app-containers/sen/sen-0.7.0.ebuild b/app-containers/sen/sen-0.7.0.ebuild
new file mode 100644
index 000000000000..84a042bbafb4
--- /dev/null
+++ b/app-containers/sen/sen-0.7.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="Terminal User Interface for docker engine"
+HOMEPAGE="https://github.com/TomasTomecek/sen"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/urwid[${PYTHON_USEDEP}]
+ dev-python/urwidtrees[${PYTHON_USEDEP}]
+ dev-python/docker[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/flexmock[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc -r docs
+}