summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-10 03:51:20 +0100
committerSam James <sam@gentoo.org>2021-08-10 03:59:24 +0100
commitb5d90e75c2af4a473e9166cccb915f91ec5d5f32 (patch)
tree3bad9b5d3d1688095b26f59e7f10a3a2985ad6de /app-backup/backintime
parentsys-fs/archivemount: add 0.9.1 (diff)
downloadgentoo-b5d90e75c2af4a473e9166cccb915f91ec5d5f32.tar.gz
gentoo-b5d90e75c2af4a473e9166cccb915f91ec5d5f32.tar.bz2
gentoo-b5d90e75c2af4a473e9166cccb915f91ec5d5f32.zip
app-backup/backintime: add 1.3.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-backup/backintime')
-rw-r--r--app-backup/backintime/Manifest1
-rw-r--r--app-backup/backintime/backintime-1.3.1.ebuild77
-rw-r--r--app-backup/backintime/backintime-9999.ebuild26
3 files changed, 92 insertions, 12 deletions
diff --git a/app-backup/backintime/Manifest b/app-backup/backintime/Manifest
index 558b875d3b7d..6c8ad7caafb0 100644
--- a/app-backup/backintime/Manifest
+++ b/app-backup/backintime/Manifest
@@ -1 +1,2 @@
DIST backintime-1.2.1.tar.gz 713853 BLAKE2B 0f05d6cdc04a41ec9737badb8693c1270bb1333b2986fce925625ba2d7be05de0630ff5f59a7b5854a38ba382d6992df1ffc4e1cb584cae0e2618b877db4f06b SHA512 91dbc76a7db81469c5a538be03196c8e307d13307486d8e1c6cad10ce0af399de495f0292fecffc2853ed78804b5899750f06f274b4701efe3af6a708ea1024e
+DIST backintime-1.3.1.tar.gz 714401 BLAKE2B 5b6a294d5a22ee3928725caf1a9895b665bfcddd6b779355cd7f7e58b5a201c3d2158ef4b30fb73eb4525c1a54cacf878397874f28b06798b7bfd973df467a39 SHA512 faac8552748da75db62cf7fa7eea686fd8b262016d1072f432fff54a6c0c72929650582870b4c56efbaa4ef5984acaece9e1d76eb72abcce91c6fc92d34d52ad
diff --git a/app-backup/backintime/backintime-1.3.1.ebuild b/app-backup/backintime/backintime-1.3.1.ebuild
new file mode 100644
index 000000000000..8a5153c4753d
--- /dev/null
+++ b/app-backup/backintime/backintime-1.3.1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} )
+
+inherit python-single-r1 xdg
+
+DESCRIPTION="Backup system inspired by TimeVault and FlyBack"
+HOMEPAGE="https://backintime.readthedocs.io/en/latest/ https://github.com/bit-team/backintime/"
+SRC_URI="https://github.com/bit-team/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples qt5"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ net-misc/openssh
+ net-misc/rsync[xattr,acl]
+ qt5? ( dev-python/PyQt5[gui,widgets] )"
+
+PATCHES=( "${FILESDIR}/${PN}-1.2.1-no-compress-docs-examples.patch" )
+
+src_configure() {
+ pushd common > /dev/null || die
+ # Not autotools
+ ./configure --python3 --no-fuse-group || die
+ popd > /dev/null || die
+
+ if use qt5 ; then
+ pushd qt > /dev/null || die
+ ./configure --python3 || die
+ popd > /dev/null || die
+ fi
+}
+
+src_compile() {
+ pushd common > /dev/null || die
+ emake
+ popd > /dev/null || die
+
+ if use qt5 ; then
+ pushd qt > /dev/null || die
+ emake
+ popd > /dev/null || die
+ fi
+}
+
+src_install() {
+ pushd common > /dev/null || die
+ emake DESTDIR="${D}" install
+ popd > /dev/null || die
+
+ if use qt5 ; then
+ pushd qt > /dev/null || die
+ emake DESTDIR="${D}" install
+ popd > /dev/null || die
+ fi
+
+ einstalldocs
+
+ if use examples ; then
+ docinto examples
+ dodoc common/{config-example-local,config-example-ssh}
+ fi
+
+ python_optimize "${D}"
+}
diff --git a/app-backup/backintime/backintime-9999.ebuild b/app-backup/backintime/backintime-9999.ebuild
index 606f837db53d..ec4851aa691d 100644
--- a/app-backup/backintime/backintime-9999.ebuild
+++ b/app-backup/backintime/backintime-9999.ebuild
@@ -13,7 +13,6 @@ EGIT_REPO_URI="https://github.com/bit-team/backintime/"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
IUSE="examples qt5"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -22,49 +21,52 @@ DEPEND="${PYTHON_DEPS}
$(python_gen_cond_dep '
dev-python/dbus-python[${PYTHON_USEDEP}]
dev-python/keyring[${PYTHON_USEDEP}]
- ')
+ ')"
+RDEPEND="${DEPEND}
net-misc/openssh
net-misc/rsync[xattr,acl]
-"
-RDEPEND="${DEPEND}
- qt5? ( dev-python/PyQt5[gui,widgets] )
-"
+ qt5? ( dev-python/PyQt5[gui,widgets] )"
PATCHES=( "${FILESDIR}/${PN}-1.2.1-no-compress-docs-examples.patch" )
src_configure() {
pushd common > /dev/null || die
- ./configure --python3 --no-fuse-group || die
+ # Not autotools
+ ./configure --python3 --no-fuse-group || die
popd > /dev/null || die
+
if use qt5 ; then
pushd qt > /dev/null || die
- ./configure --python3 || die
+ ./configure --python3 || die
popd > /dev/null || die
fi
}
src_compile() {
pushd common > /dev/null || die
- emake
+ emake
popd > /dev/null || die
+
if use qt5 ; then
pushd qt > /dev/null || die
- emake
+ emake
popd > /dev/null || die
fi
}
src_install() {
pushd common > /dev/null || die
- emake DESTDIR="${D}" install
+ emake DESTDIR="${D}" install
popd > /dev/null || die
+
if use qt5 ; then
pushd qt > /dev/null || die
- emake DESTDIR="${D}" install
+ emake DESTDIR="${D}" install
popd > /dev/null || die
fi
einstalldocs
+
if use examples ; then
docinto examples
dodoc common/{config-example-local,config-example-ssh}