summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2022-07-20 16:51:46 -0700
committerZac Medico <zmedico@gentoo.org>2022-07-21 08:23:26 -0700
commit04b48542d6f6391b87939c8dc6095d8e9ab3466c (patch)
treefc0a809e880d638c6495b63cedbad57326c990d9 /app-arch
parentprofiles: revert masking of dev-perl/Search-Xapian (diff)
downloadgentoo-04b48542d6f6391b87939c8dc6095d8e9ab3466c.tar.gz
gentoo-04b48542d6f6391b87939c8dc6095d8e9ab3466c.tar.bz2
gentoo-04b48542d6f6391b87939c8dc6095d8e9ab3466c.zip
app-arch/aptly: new package, add 1.5.0
Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/aptly/Manifest2
-rw-r--r--app-arch/aptly/aptly-1.5.0.ebuild26
-rw-r--r--app-arch/aptly/metadata.xml10
3 files changed, 38 insertions, 0 deletions
diff --git a/app-arch/aptly/Manifest b/app-arch/aptly/Manifest
new file mode 100644
index 000000000000..0cad67bbc8c4
--- /dev/null
+++ b/app-arch/aptly/Manifest
@@ -0,0 +1,2 @@
+DIST aptly-1.5.0-deps.tar.xz 162455936 BLAKE2B 2b13929b9cd9238095e0d97cf77cdfb8abce88bbf2ae48dbd3e48d9f96a12658381203b51c1ee1d87b441360d5ca7745a12b2eef54b355213de2cb2d07d59d7c SHA512 9cfa90fb3ebee66fdf1d7b859ce8d43659260f987ceb3ece9a357f9c55dab948a0f4c431fc7b80c867a06f960810c7d6f75bea7e04cf2e81e4c7eeb2a3833e2c
+DIST aptly-1.5.0.tar.gz 8334792 BLAKE2B 605dfcf4a1289cc101f3596aaa67ad64a05ed64d11dae78d3cb0219a44ed1fcda57c3225e718d27d7de7cadc0a751ed1c607849949beb3a531efcce9e8247d08 SHA512 0b48059ccce5b16c3f4b7eb33522263e0d82c7310ff6f6f515cea94de4c32caedad541acdb1bf498877cfce487c5b525d123150a83f535d76a1e219c5770a0c0
diff --git a/app-arch/aptly/aptly-1.5.0.ebuild b/app-arch/aptly/aptly-1.5.0.ebuild
new file mode 100644
index 000000000000..831d99b1b2f3
--- /dev/null
+++ b/app-arch/aptly/aptly-1.5.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd
+
+DESCRIPTION="Debian repository management tool"
+HOMEPAGE="https://www.aptly.info/"
+
+SRC_URI="https://github.com/aptly-dev/aptly/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~zmedico/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT Apache-2.0 BSD BSD-2 ISC MPL-2.0 WTFPL-2 ZLIB"
+RESTRICT+=" test"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ emake install
+}
+
+src_install() {
+ dobin ~/go/bin/aptly
+ dodoc README.rst
+ systemd_dounit aptly.service aptly-api.service
+}
diff --git a/app-arch/aptly/metadata.xml b/app-arch/aptly/metadata.xml
new file mode 100644
index 000000000000..907cab2e50fb
--- /dev/null
+++ b/app-arch/aptly/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">aptly-dev/aptly</remote-id>
+ </upstream>
+</pkgmetadata>