summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-arch/pure-sfv
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-arch/pure-sfv')
-rw-r--r--app-arch/pure-sfv/Manifest1
-rw-r--r--app-arch/pure-sfv/files/pure-sfv-0.3-asneeded.patch11
-rw-r--r--app-arch/pure-sfv/metadata.xml11
-rw-r--r--app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild35
4 files changed, 58 insertions, 0 deletions
diff --git a/app-arch/pure-sfv/Manifest b/app-arch/pure-sfv/Manifest
new file mode 100644
index 000000000000..116e350bac51
--- /dev/null
+++ b/app-arch/pure-sfv/Manifest
@@ -0,0 +1 @@
+DIST pure-sfv_0.3_src.tar.gz 79069 SHA256 b5dc97e96656dbe397439c85b0b8ecebddd9d350a09a7485c653ff9210989321 SHA512 defacdaa0b78f708c83198e911ad93a5c5456bf15e2b33df61c984241df8a82ff4d962b8c7994c6413b36a61df2cc6d91c467bf8994fa43e0ac01db2585a78a6 WHIRLPOOL 2befa4d4dd6e0e043e50ca4b69e0024c71c68483af52ffe13bbac569d6f9482d5d167e25e918ddf314cf950e88e7271813c05fd2d1e0177ac6177a619ed7451e
diff --git a/app-arch/pure-sfv/files/pure-sfv-0.3-asneeded.patch b/app-arch/pure-sfv/files/pure-sfv-0.3-asneeded.patch
new file mode 100644
index 000000000000..926dd1318bdc
--- /dev/null
+++ b/app-arch/pure-sfv/files/pure-sfv-0.3-asneeded.patch
@@ -0,0 +1,11 @@
+--- Makefile.orig 2009-01-03 18:36:24.349399478 +0100
++++ Makefile 2009-01-03 18:36:37.218398964 +0100
+@@ -65,7 +65,7 @@
+ OBJ = ${SRCS:%.c=%.o}
+
+ pure-sfv: $(OBJ)
+- $(CC) -lm -DVERSION=\"$(VERSION)\" $(CFLAGS) -o $(PROG) $(OBJ)
++ $(CC) -DVERSION=\"$(VERSION)\" $(CFLAGS) $(LDFLAGS) -o $(PROG) $(OBJ) -lm
+
+ PURIFY_OPTIONS=-follow-child-processes=yes -always-use-cache-dir=yes
+ PURIFY=purify
diff --git a/app-arch/pure-sfv/metadata.xml b/app-arch/pure-sfv/metadata.xml
new file mode 100644
index 000000000000..174e6155e7df
--- /dev/null
+++ b/app-arch/pure-sfv/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ <description>This package lacks a primary herd or maintainer.</description>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">pure-sfv</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild b/app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild
new file mode 100644
index 000000000000..08af26cabeb5
--- /dev/null
+++ b/app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="utility to test and create .sfv files and create .par files"
+HOMEPAGE="http://pure-sfv.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pure-sfv/${PN}_${PV}_src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ppc x86"
+IUSE=""
+RESTRICT="test"
+
+DEPEND=""
+
+S="${WORKDIR}"
+
+src_prepare() {
+ sed -i Makefile -e "s:-Werror -O2 -g::"
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ dobin pure-sfv || die "dobin failed"
+ dodoc ReadMe.txt
+}