summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Feldman <NP-Hardass@gentoo.org>2021-06-10 11:15:27 -0400
committerAdam Feldman <NP-Hardass@gentoo.org>2021-06-30 18:41:49 -0400
commit97b4abc23e3df07e8f0b301f09b94ce107022b06 (patch)
tree1b59fdd47d24c0444d61be863fce2a52740dc40a /app-arch/engrampa/engrampa-1.24.2.ebuild
parentapp-text/atril: Bump to 1.24.1 (diff)
downloadgentoo-97b4abc23e3df07e8f0b301f09b94ce107022b06.tar.gz
gentoo-97b4abc23e3df07e8f0b301f09b94ce107022b06.tar.bz2
gentoo-97b4abc23e3df07e8f0b301f09b94ce107022b06.zip
app-arch/engrampa: Bump to 1.24.2
Bug: https://bugs.gentoo.org/778857 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
Diffstat (limited to 'app-arch/engrampa/engrampa-1.24.2.ebuild')
-rw-r--r--app-arch/engrampa/engrampa-1.24.2.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/app-arch/engrampa/engrampa-1.24.2.ebuild b/app-arch/engrampa/engrampa-1.24.2.ebuild
new file mode 100644
index 000000000000..506779c08365
--- /dev/null
+++ b/app-arch/engrampa/engrampa-1.24.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE_LA_PUNT="yes"
+
+inherit mate readme.gentoo-r1
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Engrampa archive manager for MATE"
+LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
+SLOT="0"
+
+IUSE="caja magic packagekit"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/json-glib-0.14
+ virtual/libintl
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3[X]
+ x11-libs/libSM
+ x11-libs/pango
+ caja? ( >=mate-base/caja-1.17.1 )
+ magic? ( sys-apps/file )
+ packagekit? ( app-admin/packagekit-base )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+ !!app-arch/mate-file-archiver
+"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ mate_src_configure \
+ --disable-run-in-place \
+ $(use_enable caja caja-actions) \
+ $(use_enable magic) \
+ $(use_enable packagekit)
+}
+
+pkg_postinst() {
+ mate_pkg_postinst
+ optfeature "Support for 7-zip" app-arch/p7zip
+ optfeature "Support for ace" app-arch/unace
+ optfeature "Support for arj" app-arch/arj
+ optfeature "Support for cpio" app-arch/cpio
+ optfeature "Support for deb" app-arch/dpkg
+ optfeature "Support for iso" app-cdr/cdrtools
+ optfeature "Support for jar,zip" app-arch/zip app-arch/unzip
+ optfeature "Support for lha" app-arch/lha
+ optfeature "Support for lzma" app-arch/xz-utils
+ optfeature "Support for lzop" app-arch/lzop
+ optfeature "Support for rar" app-arch/unrar
+ optfeature "Support for rpm" app-arch/rpm
+ optfeature "Support for unstuff" app-arch/stuffit
+ optfeature "Support for zoo" app-arch/zoo
+}