summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-31 07:31:51 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-31 08:54:53 +0200
commiteac7fc9133cb52e6d17f9cf9e0b63a6ef622a515 (patch)
tree02d495ad5c3790594b520740626c3a7d2b4646dc /app-admin
parentdev-python/boto3: Bump to 1.35.10 (diff)
downloadgentoo-eac7fc9133cb52e6d17f9cf9e0b63a6ef622a515.tar.gz
gentoo-eac7fc9133cb52e6d17f9cf9e0b63a6ef622a515.tar.bz2
gentoo-eac7fc9133cb52e6d17f9cf9e0b63a6ef622a515.zip
app-admin/awscli: Bump to 1.34.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.34.10.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 436c510bec32..962b82b7bb27 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -1,5 +1,6 @@
DIST aws-cli-1.33.40.gh.tar.gz 2769444 BLAKE2B a26e26cb4694460e36fe2d9730092db33aff74e436642f3de5f94dc2fcbb594bb1ef2db425584359f50d0ae37be8be6034a0e722968a0ea4179e888b2f23be7c SHA512 d19d762a1ca0b02f3076d9241be19755f74c2b228cdb258f873d73dc91f25730b40e4a82bed3cb77e94b30ba34e1260629a3af6e7a7b7df108522d21103f34bb
DIST aws-cli-1.34.0.gh.tar.gz 2773056 BLAKE2B c6c9d89fe719116faad47417dd1aa9a98125b65efaf61476582cf7fec16e7ab5bd9823b6973bde51891a8bdad8ec9bfade305abfcee2eb70f6cf2679ef815d1b SHA512 914efb62ec94825529e981c934f617b0c1ae3c367b7215bff7160b8bef7c3ea73d0400d3e04ff237546731e3586077c83ed918c0747f75ff4079e8b5e1159809
+DIST aws-cli-1.34.10.gh.tar.gz 2788517 BLAKE2B 8b110119087836435f3e0ef29a6cfe35dd3a387bff4051cc94b9beb4e8a2d929460ac14c659ef0c3a37cb6378e7910eca7c92975f04ac2d1b2140e2aedd0eb60 SHA512 46844c919a3998040897ccdf48cf4ed616a9debc125d03386f53bce66597a8cc077f9be7735b133085c3225c9402acd94da85fffbd1205e732ad5cd5b56bf9a2
DIST aws-cli-1.34.5.gh.tar.gz 2774000 BLAKE2B 34368cc257a99a9c7212972bcff91c46352db8659c5fe98101c9192cb674663b9090b3608d88875875d24488869fcb571e8602532219cf0a25bc3159f3bf285c SHA512 4dc305e4e659fbbd17a265b6c9589e20c63eec671114a67687c225081f8095a8627499441f78d76e6fa0da59b03ae078833227db0434c97572a7f5f7c4a43e5a
DIST aws-cli-1.34.6.gh.tar.gz 2774042 BLAKE2B 7ba1692ad62128f01f3d082897098f75f010f1eedb0f4f76b434368d64e470900391d94e4f1c857dcbf971c3de65f36adea8c9279f323c4a120c762183942208 SHA512 3e32fa61fb6b1a139b9f89c4b36172b2cf4e31828c66f6e33d93be2debf7c55331780e373a6597fda0e33683554cbeb53bddd6ae9fef90b8a55193bbecb8c3ea
DIST aws-cli-1.34.7.gh.tar.gz 2785707 BLAKE2B d70383edd80aae01315faaaef9676f7a56fec0f10f04745cc5bed731a2d3b88657af782f7b3f966d0d003eb99d55fa559530c4327541c342ab76b56e710ac5b8 SHA512 4b53cd5963eeec51038f3e04b0d2dd87acb08032925a15245674b23444f5f9801a48992e60f75e143b88c794df8d142f26108ad2fde775172f397164901cd3cf
diff --git a/app-admin/awscli/awscli-1.34.10.ebuild b/app-admin/awscli/awscli-1.34.10.ebuild
new file mode 100644
index 000000000000..599b9bd389b9
--- /dev/null
+++ b/app-admin/awscli/awscli-1.34.10.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1 )).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}