summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-13 05:29:38 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-13 05:29:38 +0200
commitb75449c25dd258c148fc65e782de778f96c0c27b (patch)
treea78cc0c7e5b889f4ad27208282bc1958d3bec367 /app-admin
parentdev-python/boto3: Bump to 1.34.144 (diff)
downloadgentoo-b75449c25dd258c148fc65e782de778f96c0c27b.tar.gz
gentoo-b75449c25dd258c148fc65e782de778f96c0c27b.tar.bz2
gentoo-b75449c25dd258c148fc65e782de778f96c0c27b.zip
app-admin/awscli: Bump to 1.33.26
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.33.26.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 40c7032cdf0a..09140fd03858 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -4,3 +4,4 @@ DIST aws-cli-1.33.22.gh.tar.gz 2754043 BLAKE2B 8645a55cc6f0570ce0e69599e010c9801
DIST aws-cli-1.33.23.gh.tar.gz 2753877 BLAKE2B e7babf49849a43a6f69b029ff3e27bcc1014498dfcc0a3711ca71aea7f992a3ac16ee21804767314d8141e7413a107227a66de45a83ea478782ef2b9028249a3 SHA512 22a81a95f2fea6ffd180c4003e074655cc6470e949ab4b99120dae17778fedbd56d11fcceb51f8d89eec4ef6a1b659cc986abf34fa26cd77cd5a58b59342f4aa
DIST aws-cli-1.33.24.gh.tar.gz 2754563 BLAKE2B c2e2e8e939929909da58e055bc97d65fc4f6df254e596dd8aac57c2bf82dabba9eeb29c9c8c8d8fd1ccd22d8c7fe20127b9801963f127b5ba008c6918e1307c5 SHA512 d830150f802fd093076041f113bb052d9049828d02cd03d161f386e326ff7b56d151189d9e33f3d1e4e7871f6fdf5624f205962353e92436c0782b4f8effc127
DIST aws-cli-1.33.25.gh.tar.gz 2755746 BLAKE2B 97349bb65e77c4689978d4498d688f75acd3a1fdaf0c0f742a7cc9175a12fb781cb43f36517c5bf69a34b3c4b7a9b3609ccc6942ed5829ba10af20e1ad98e841 SHA512 b086941b6d37f6333937a5060ff44aaa82977a55db3ac2b51a5091b457ab2d228044d4603c6b6633467cd566a84e6b6abe6d91e129697a97a233fc9cf104ff55
+DIST aws-cli-1.33.26.gh.tar.gz 2757281 BLAKE2B 04d88160203ff9cfc0c0f22dd9d57c70e95289af769b4639708bc6a760d32b324fe4785def2cfdf17abadfbfd04a2ef974979dd3b9ac6342bea230a297b7c022 SHA512 e4ce9037042edfdeb36a8bfd74f7998664838598af066cf324245ddc04555037f0ff7b69f1e2dbf0cb727932ef9a6c0feef8acafaed00e5b0c94b1b9e59a6c2d
diff --git a/app-admin/awscli/awscli-1.33.26.ebuild b/app-admin/awscli/awscli-1.33.26.ebuild
new file mode 100644
index 000000000000..c212ce9cac21
--- /dev/null
+++ b/app-admin/awscli/awscli-1.33.26.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+1).(z+118), sigh
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1 )).$(( $(ver_cut 3-) + 118 ))"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}