summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-26 05:52:21 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-26 06:49:44 +0200
commit8f5e19983ab700b54d31aac121e6ad5d79cd4f07 (patch)
tree5d4f619c934971ef86968c91f9c5dc0617311a6c /app-admin
parentdev-python/boto3: Bump to 1.35.27 (diff)
downloadgentoo-8f5e19983ab700b54d31aac121e6ad5d79cd4f07.tar.gz
gentoo-8f5e19983ab700b54d31aac121e6ad5d79cd4f07.tar.bz2
gentoo-8f5e19983ab700b54d31aac121e6ad5d79cd4f07.zip
app-admin/awscli: Bump to 1.34.27
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.34.27.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 9501b4c6bc55..c6e897a3159b 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -3,3 +3,4 @@ DIST aws-cli-1.34.19.gh.tar.gz 2795240 BLAKE2B ede95bb83dffdef1cbc6896f35e6926e3
DIST aws-cli-1.34.24.gh.tar.gz 2798088 BLAKE2B 24d5b74da8e6e1b97cd8c3558d28581acbb48250caa0a33ad9635068a358b6a0e450446d1486783e4208bb067f00616cb4c708c1674bb43ac3f9b7630d4116d2 SHA512 cb1d9fcf322e68a69f732a95c39701d937e83ea91a73b93dc565a7bb575c0f79b6a3cf0f47253321b3e54d9c5824b054798f53f5f82f9a29f94758c3a19aa4f9
DIST aws-cli-1.34.25.gh.tar.gz 2799069 BLAKE2B 1f1a09b6b4b915570a67ebb9374799bd90e71e4286d356e19c74c5e27d1786ce01fdbca863cc2709c5f96219222348e23a36a779c1b90b6aa2b4112497428495 SHA512 c95b6064d249e7d96676f7dcd66d414f6f1699643a090d61aceed4c929e2c6cee6d9e5f0155e8b7e5ded29227e800ab6d2de79b6dde0dd00a2b62b7dd3541c72
DIST aws-cli-1.34.26.gh.tar.gz 2799245 BLAKE2B 99762018d1f78f89526522f6b75dae2711138e3c5e404e29a1527cce812195895e6e1e8f429f63db2532f4e756591195aeb0fcf506a545a45320f182af60882e SHA512 c816dfdcde58832b86da8645f5e38118783fa1e0c320aceaf25477b1c703a28636395bdf6addf0b32c0c6124361957459165a81dc53e06beda31786fea7206b7
+DIST aws-cli-1.34.27.gh.tar.gz 2799479 BLAKE2B fc5a52b4d685476874e7833897eab963e6276a24f99fceb344feebf44dd2444ea3aa2c3d1c74d9e308d4aceec77e35d9992e7af92fb5d927af7187fab4ba57a0 SHA512 1ad22b63046963ffc6cba82e07503332ca8b6cca255b686910a9325f43f3595fc7d4076fb4681a0e8d2b731aee5664ef50bf49fa18bbdca4266e334945c70b10
diff --git a/app-admin/awscli/awscli-1.34.27.ebuild b/app-admin/awscli/awscli-1.34.27.ebuild
new file mode 100644
index 000000000000..599b9bd389b9
--- /dev/null
+++ b/app-admin/awscli/awscli-1.34.27.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1 )).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}