summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-24 06:59:39 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-24 06:59:39 +0200
commit878a3d2a0b3ca1ee15f96db1fcbefae3fd5d7ad5 (patch)
tree3acee9a48026281df70e97c5578074f316447131 /app-admin
parentdev-python/boto3: Bump to 1.35.5 (diff)
downloadgentoo-878a3d2a0b3ca1ee15f96db1fcbefae3fd5d7ad5.tar.gz
gentoo-878a3d2a0b3ca1ee15f96db1fcbefae3fd5d7ad5.tar.bz2
gentoo-878a3d2a0b3ca1ee15f96db1fcbefae3fd5d7ad5.zip
app-admin/awscli: Bump to 1.34.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.34.5.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 52109cdaba33..ec3d2e1d4e49 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -5,3 +5,4 @@ DIST aws-cli-1.34.1.gh.tar.gz 2773592 BLAKE2B 38dab4a072a807c9f8dc57f6ac97e7c756
DIST aws-cli-1.34.2.gh.tar.gz 2773948 BLAKE2B 71ccdb3898087ad8e51cbd49253e4a999cf10c8cb4d719acd4d5e0adfff73920da8fea8702accb5fc408c43cf86c903736704b6350df30620bae2049e7c8bf83 SHA512 a983b3ed870717c81bd79bc9d436bde12585d396a43d4652c52795541c551fa88a48929a7319f1124abc02a259fbadfe2d261304b49267a4bf64688215ad7dfe
DIST aws-cli-1.34.3.gh.tar.gz 2772150 BLAKE2B 4cd6f36a6987e4d58130d26c60d3254258d24d1065a0834aa5cb987cf51f7d2a6049e05253f63ac0a11cd4f2d4a94b68affb2195d51db8a57fe0a1808f55dca4 SHA512 2ee6a5bb5b2565913f6f70ff8a1c8b9561034019857016cf548b0c683ee67d98095a0572d692a531250f933302b673ba5a8f9c42e73cf5c385236fc1ca14821e
DIST aws-cli-1.34.4.gh.tar.gz 2773571 BLAKE2B 3438b900053da8aa915941d79a2c7d36bd01b9043a8ff6ff4c50ee34f061fb821b6ad9d6085924358dcf518ab08b9827fce96da573599cb0395f4a9081450654 SHA512 c335bbe31db807e43b63daacb7e7050ef0ecf477f3bb2ca043f3325e327d06041aa67bb2ed3b588f8acc1fea501479fc8d501ac136f181d1fab7516f328317b2
+DIST aws-cli-1.34.5.gh.tar.gz 2774000 BLAKE2B 34368cc257a99a9c7212972bcff91c46352db8659c5fe98101c9192cb674663b9090b3608d88875875d24488869fcb571e8602532219cf0a25bc3159f3bf285c SHA512 4dc305e4e659fbbd17a265b6c9589e20c63eec671114a67687c225081f8095a8627499441f78d76e6fa0da59b03ae078833227db0434c97572a7f5f7c4a43e5a
diff --git a/app-admin/awscli/awscli-1.34.5.ebuild b/app-admin/awscli/awscli-1.34.5.ebuild
new file mode 100644
index 000000000000..599b9bd389b9
--- /dev/null
+++ b/app-admin/awscli/awscli-1.34.5.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1 )).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}