summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-30 02:51:03 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-30 03:38:21 +0200
commit7df12a21be47d50066a5112c927466b90ed28976 (patch)
tree0973aecde4108d08e9200e78c10b5c70520c32a0 /app-admin
parentdev-python/boto3: Bump to 1.35.9 (diff)
downloadgentoo-7df12a21be47d50066a5112c927466b90ed28976.tar.gz
gentoo-7df12a21be47d50066a5112c927466b90ed28976.tar.bz2
gentoo-7df12a21be47d50066a5112c927466b90ed28976.zip
app-admin/awscli: Bump to 1.34.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.34.9.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index ca5f5cb476ed..436c510bec32 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -4,3 +4,4 @@ DIST aws-cli-1.34.5.gh.tar.gz 2774000 BLAKE2B 34368cc257a99a9c7212972bcff91c4635
DIST aws-cli-1.34.6.gh.tar.gz 2774042 BLAKE2B 7ba1692ad62128f01f3d082897098f75f010f1eedb0f4f76b434368d64e470900391d94e4f1c857dcbf971c3de65f36adea8c9279f323c4a120c762183942208 SHA512 3e32fa61fb6b1a139b9f89c4b36172b2cf4e31828c66f6e33d93be2debf7c55331780e373a6597fda0e33683554cbeb53bddd6ae9fef90b8a55193bbecb8c3ea
DIST aws-cli-1.34.7.gh.tar.gz 2785707 BLAKE2B d70383edd80aae01315faaaef9676f7a56fec0f10f04745cc5bed731a2d3b88657af782f7b3f966d0d003eb99d55fa559530c4327541c342ab76b56e710ac5b8 SHA512 4b53cd5963eeec51038f3e04b0d2dd87acb08032925a15245674b23444f5f9801a48992e60f75e143b88c794df8d142f26108ad2fde775172f397164901cd3cf
DIST aws-cli-1.34.8.gh.tar.gz 2787252 BLAKE2B 5886bcee0ce088c32c3e7e8f4eedf9e9d4e43f24412e1bc078d70ec71b099e4cc9729258fc4d88379fa59f532eda93e129f61d303fabcb082036e3ec32aa043d SHA512 06ff76ab9759adbbc5d8c8d3373e15366cba564845c038c4ae4211a249115fa41aaebdeb75f5443f4499b1bb1a0680dd9ab6d313569fde6b9f400f831dc13971
+DIST aws-cli-1.34.9.gh.tar.gz 2787637 BLAKE2B f1723a6fac1aa57e4db5b23c673f74696e4e05f9c6403d84cad29af415f16335851a74354908ef1f67a717cbc9ba7522b2b6ded1a8f2d0b808f8db0fed51819a SHA512 636ad8cd7062ad88e0838817f496c7fd9f3f53a188b313ecab8aaa579107ac9a940114b99a392d6460e9276388cccf802d24bd087e4f9dd4ab47d6ca179fd2ed
diff --git a/app-admin/awscli/awscli-1.34.9.ebuild b/app-admin/awscli/awscli-1.34.9.ebuild
new file mode 100644
index 000000000000..599b9bd389b9
--- /dev/null
+++ b/app-admin/awscli/awscli-1.34.9.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 1 )).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}