summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2024-07-19 14:23:38 +0200
committerAgostino Sarubbo <ago@gentoo.org>2024-07-19 14:23:38 +0200
commit3f405823149efb0335090900c82f01a096af4d79 (patch)
tree838ca0c507d9cd76c06067de697efd8f9f848d04 /app-admin
parentnet-mail/gnubiff: Stabilize 2.2.17-r3 amd64, #936298 (diff)
downloadgentoo-3f405823149efb0335090900c82f01a096af4d79.tar.gz
gentoo-3f405823149efb0335090900c82f01a096af4d79.tar.bz2
gentoo-3f405823149efb0335090900c82f01a096af4d79.zip
app-admin/exo: add 1.78.4
Signed-off-by: Agostino Sarubbo <ago@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/exo/Manifest1
-rw-r--r--app-admin/exo/exo-1.78.4.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-admin/exo/Manifest b/app-admin/exo/Manifest
index 8d8ded050f48..9ac3313d1957 100644
--- a/app-admin/exo/Manifest
+++ b/app-admin/exo/Manifest
@@ -1 +1,2 @@
DIST exo-1.78.2.gh.tar.gz 11084100 BLAKE2B 56cf1212040df77d2e39bbc90490276563a45632fe47f1781bba84fe5d99634a6d050c52dd15c9bb837e7ebef2ea21087a5c50cc165b0b606a0f3e9b4f59182a SHA512 1f2b3fedd12a00457e241b0d00eb4235804b60c8c8e6bec1f970617a969761eb9e18c10a6031bffba6c58571ca7049c47d8eb74f3fbaacb095ef72b21bea1c20
+DIST exo-1.78.4.gh.tar.gz 11118919 BLAKE2B cae6863c14d54363973491cb08a628abe24043ad8ae81aaf712c0b3ddf6c2037aca0f9b9e6a8323695558011999a0022fd151dcfb7df38409d0dfead58b9b7b8 SHA512 334ac58e899c40faed197cc11ae234ee3f8226bf51feb7bb552169710ffecababe469994d6096f5367edb424d5ccd0ac6521ff8fd83c521b9397196dd72d4cf6
diff --git a/app-admin/exo/exo-1.78.4.ebuild b/app-admin/exo/exo-1.78.4.ebuild
new file mode 100644
index 000000000000..43fbacd8aa32
--- /dev/null
+++ b/app-admin/exo/exo-1.78.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="Command-line tool for everything at Exoscale: compute, storage, dns"
+HOMEPAGE="https://github.com/exoscale/cli"
+SRC_URI="https://github.com/exoscale/cli/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/cli-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=">=dev-lang/go-1.16:="
+RESTRICT="strip"
+
+src_compile() {
+ ego build -mod vendor -o ${PN} -ldflags "-X main.version=${PVR}-gentoo -X main.commit="
+}
+
+src_test() {
+ # run at least 'exo version' for test
+ ./exo version > /dev/null 2>&1
+ if [[ $? -ne 0 ]]
+ then
+ die "Test failed"
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+}