summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-17 07:25:51 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-17 08:25:35 +0200
commit3c369d8bcf8f9f6dedfbf13704f3ef0728d8a9ed (patch)
treeb87c28aa21ff84b6d40682510e18a52e32da2ad1 /app-admin
parentdev-python/boto3: Bump to 1.34.107 (diff)
downloadgentoo-3c369d8bcf8f9f6dedfbf13704f3ef0728d8a9ed.tar.gz
gentoo-3c369d8bcf8f9f6dedfbf13704f3ef0728d8a9ed.tar.bz2
gentoo-3c369d8bcf8f9f6dedfbf13704f3ef0728d8a9ed.zip
app-admin/awscli: Bump to 1.32.107
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.32.107.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index d03d195e0e6b..c06cbe86ca27 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -2,5 +2,6 @@ DIST aws-cli-1.32.103.gh.tar.gz 2726436 BLAKE2B 7c08f29df7b0f786a99a7469263cb367
DIST aws-cli-1.32.104.gh.tar.gz 2726763 BLAKE2B 997fc73890d033485fb22cf7c5e6ab2844aaec60fe2017cea2513f4f439f6fab8c70519a5ded46ed269b3733eed52579236e577d8db172448812128c68687d50 SHA512 a416f93d77a7f314294aff14a337dbea1ae7d5ef10221a97abec71f8b4c23d764455b4bcb48d10fc5cbb1fcc9cfb149bc4b49e102d0e488a8f3bd4d91782878c
DIST aws-cli-1.32.105.gh.tar.gz 2727065 BLAKE2B 1ddbb3405e491fac1257936647872beb93f374754f718338cca1d6ddf230feb3ac4b167af36a1f2a351553af7ea0b525d6481bc06a9d469c79ad06134d1e1da2 SHA512 a181ca52de6f1c891ceb12958927040751e7890b505d1dd2ab1400f1fa17ba555ff2e2fa5a542113648991b37ce99d8016f00e863f81b56e783c28169d7cc993
DIST aws-cli-1.32.106.gh.tar.gz 2727416 BLAKE2B 6749a4f63ca594c344a80751fc0ac0f3434c4b5c8a93db794f89d10a23369941656067b00fd66da72d4dd081a920e51a57572d028953356c9c5ad6ebfc1dccf1 SHA512 d6103bbacd65b94f4289d332bf18895899a5caa9c201bb62601863c86a07f8b97dd58651c0e8f2665b322e5d6ea3ac8d2bec2cdeac391cefe0cd03488a02fefc
+DIST aws-cli-1.32.107.gh.tar.gz 2727905 BLAKE2B 6790687edadc7ebf4bb8519ed9352961d002b95b157bf56b3ce02f50eef8e9eeeac39bb211816ab3e8e0f21dc2e41b9b3c179c77eab8c23d5650b1002fafff52 SHA512 b2f363ba8833058eb935fab311492c252dac4afff2f81e5ea70b9a8610c6e5b7e0b4ec090591af1a0c3692c3641ac1213cb8455d8ffac8a148d7ba0b7c7f4467
DIST aws-cli-1.32.93.gh.tar.gz 2695489 BLAKE2B d2f81786d4db158a13ec50ed833668db26bde00cc1e4f5254aa127aba82113074abafa996f525b5f7cd215fd51639481a01a49c425bb4c01e990261529f06082 SHA512 e03892ef522fa43442d1b053d0bf8dbd6c892d94398934c4af58e81153c2759f7e55a289457bb3e5b46f2f01697642498fdd6d51cdc18ad8b6c0f6a31d7c606a
DIST aws-cli-1.32.98.gh.tar.gz 2723261 BLAKE2B f854a78226a9480d2966e0dcc817e372de96f32723c28bd7189ed484ab24e8fa9f33a018b1b3193d1a5be82e1ad2b69b2d0d6642f004aa6fd601a68862cbbbdc SHA512 989ad96da152423001832a502935ed64a92ef61ba63f9f413fa07e84910d2aa905056bbfcf49202508d6d0a910b4a2969da27e736857e918077693909e4ca0ea
diff --git a/app-admin/awscli/awscli-1.32.107.ebuild b/app-admin/awscli/awscli-1.32.107.ebuild
new file mode 100644
index 000000000000..4a677affdbc4
--- /dev/null
+++ b/app-admin/awscli/awscli-1.32.107.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}