summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-01-23 09:58:24 -0600
committerWilliam Hubbs <williamh@gentoo.org>2024-01-23 09:58:49 -0600
commitd567383b1d19741b6afe75d52ce560e4ed4f0f3d (patch)
tree21528420960c5246f78d44ecdb433bb697e06c4d /app-admin/opentofu
parentprofiles: workaround sandbox bug with getcwd() configure test (gl_cv_func_get... (diff)
downloadgentoo-d567383b1d19741b6afe75d52ce560e4ed4f0f3d.tar.gz
gentoo-d567383b1d19741b6afe75d52ce560e4ed4f0f3d.tar.bz2
gentoo-d567383b1d19741b6afe75d52ce560e4ed4f0f3d.zip
app-admin/opentofu: new package, add 1.6.0
Closes: https://bugs.gentoo.org/916755 Closes: https://github.com/gentoo/gentoo/pull/34248 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-admin/opentofu')
-rw-r--r--app-admin/opentofu/Manifest2
-rw-r--r--app-admin/opentofu/metadata.xml12
-rw-r--r--app-admin/opentofu/opentofu-1.6.0.ebuild40
3 files changed, 54 insertions, 0 deletions
diff --git a/app-admin/opentofu/Manifest b/app-admin/opentofu/Manifest
new file mode 100644
index 000000000000..0ceee9976ba8
--- /dev/null
+++ b/app-admin/opentofu/Manifest
@@ -0,0 +1,2 @@
+DIST opentofu-1.6.0-deps.tar.xz 332007504 BLAKE2B 1c2a7d2350944d34308baa0566977aad914b3c4f989ba90d51cb52e3001d11e56952906b0dab7adc5cef261290b748c0567e35c66f6701d62d750e18d0acea5f SHA512 5c5644b2caef5439e50865569abec133ba57a6e6581d8f8d38500671818079b471afcd86422858475b1ca912bdb75fe0b91227012f5c597bcaabe1a215b2eb09
+DIST opentofu-1.6.0.tar.gz 3696642 BLAKE2B e224ce14f04d07638d03b9a11ab251cd820acc86774f9c82f38f5bcfc38b62bbdbc70377e722a4dd2bd65f917ba0fc200ccaaeafdbd9430af66586491c7627eb SHA512 758f4ff79e526e9494e1e98dd927dbeb803b45df1f8bc15c3a9bca8343d7285b9130bfe5f19f6ddd7fd403b72d852b0d51542c058174e4bd5eed3c729b394bdb
diff --git a/app-admin/opentofu/metadata.xml b/app-admin/opentofu/metadata.xml
new file mode 100644
index 000000000000..cbe6b0ede320
--- /dev/null
+++ b/app-admin/opentofu/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+ <upstream>
+ <changelog>https://github.com/opentofu/opentofu/blob/main/CHANGELOG.md</changelog>
+ <remote-id type="github">opentofu/opentofu</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-admin/opentofu/opentofu-1.6.0.ebuild b/app-admin/opentofu/opentofu-1.6.0.ebuild
new file mode 100644
index 000000000000..544c2e0b5f16
--- /dev/null
+++ b/app-admin/opentofu/opentofu-1.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="The open source infrastructure as code tool"
+HOMEPAGE="https://www.opentofu.org/"
+SRC_URI="https://github.com/opentofu/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 MPL-2.0 MIT ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="dev-go/gox"
+
+RESTRICT="test"
+
+DOCS=( {README,CHANGELOG}.md )
+
+src_compile() {
+ export CGO_ENABLED=0
+ gox \
+ -os=$(go env GOOS) \
+ -arch=$(go env GOARCH) \
+ -output bin/tofu \
+ -verbose \
+ ./cmd/tofu || die
+}
+
+src_install() {
+ dobin bin/*
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog "If you would like to install shell completions please run:"
+ elog " tofu -install-autocomplete"
+}