summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2023-03-25 12:29:33 +0100
committerConrad Kostecki <conikost@gentoo.org>2023-04-07 22:05:31 +0200
commitd46d69d05ef2a6943273609254e575111b4c3a97 (patch)
treed144a19553507c9e646f1d2870743e5fcd5a75a8 /app-admin/mktwpol
parentmedia-video/vdr: fix filename of ttxtsubs patch (diff)
downloadgentoo-d46d69d05ef2a6943273609254e575111b4c3a97.tar.gz
gentoo-d46d69d05ef2a6943273609254e575111b4c3a97.tar.bz2
gentoo-d46d69d05ef2a6943273609254e575111b4c3a97.zip
app-admin/mktwpol: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/30339 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'app-admin/mktwpol')
-rw-r--r--app-admin/mktwpol/mktwpol-1.0.1-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/app-admin/mktwpol/mktwpol-1.0.1-r1.ebuild b/app-admin/mktwpol/mktwpol-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..a4a15455f6d9
--- /dev/null
+++ b/app-admin/mktwpol/mktwpol-1.0.1-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Bash scripts to install tripwire and generate tripwire policy files"
+HOMEPAGE="https://sourceforge.net/projects/mktwpol"
+SRC_URI="mirror://sourceforge/mktwpol/${P}.tar.gz"
+S=${WORKDIR}/${P}
+
+LICENSE="CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="app-admin/tripwire"
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's:/usr/local:/usr:' \
+ -e "s|^docdir.*|docdir = \"${EPREFIX}/usr/share/doc/${PF}\"|g" \
+ Makefile || die
+}
+
+pkg_preinst() {
+ # one elog message for new/first installation
+ # different elog message when updating
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog
+ elog "To facilitate a new installation and setup of tripwire:"
+ elog " - Run: \`twsetup.sh\`"
+ elog
+ elog "To update tripwire database as packages are added or deleted:"
+ elog " - Run: \`mktwpol.sh -u\`"
+ elog
+ elog "Mktwpol is packaged with multiple policy-generating rules files."
+ elog "A default \"rules file\" is installed in /etc/tripwire"
+ elog "Alternatives are available in /usr/share/doc/${PF}"
+ elog
+ elog "mktwpol.sh uses the policy-generating rules file with the"
+ elog "most recent date. To use an alternative \"rules file\","
+ elog "copy it from /usr/share/doc/${PF} to /etc/tripwire,"
+ elog " uncompress it, and \`touch\` it."
+ elog
+ elog "Read /usr/share/doc/${PF}/README for more tips."
+ elog
+ else
+ elog
+ elog "Version bump: mktwpol policy-generating rules have changed."
+ elog "Run \`mktwpol.sh -u\` to update tripwire policy and database."
+ elog
+ elog "Alternative policy-generating rules are in /usr/share/doc/${PF}"
+ elog "To use an alternative policy-generating rules file,"
+ elog "copy it to /etc/tripwire, uncompress and \`touch\` it."
+ elog
+ fi
+}