summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2017-08-06 18:36:14 +0200
committerAmy Liffey <amynka@gentoo.org>2017-08-06 18:36:50 +0200
commit23c24c7d829842ecf266a794e779eaf1e6db07ed (patch)
tree4d5a534f4564fc615f76acb75f05a9157bcd8f09 /app-admin/ide-smart
parentdev-libs/libdbusmenu: Fix building w/ USE=-test (diff)
downloadgentoo-23c24c7d829842ecf266a794e779eaf1e6db07ed.tar.gz
gentoo-23c24c7d829842ecf266a794e779eaf1e6db07ed.tar.bz2
gentoo-23c24c7d829842ecf266a794e779eaf1e6db07ed.zip
app-admin/ide-smart: eapi bump to 6
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-admin/ide-smart')
-rw-r--r--app-admin/ide-smart/ide-smart-1.4-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-admin/ide-smart/ide-smart-1.4-r2.ebuild b/app-admin/ide-smart/ide-smart-1.4-r2.ebuild
new file mode 100644
index 000000000000..d6ec39958880
--- /dev/null
+++ b/app-admin/ide-smart/ide-smart-1.4-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A tool to read SMART information from harddiscs"
+HOMEPAGE="http://www.linalco.com/comunidad.html http://www.linux-ide.org/smart.html"
+SRC_URI="http://www.linalco.com/ragnar/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} -Wall ${LDFLAGS} -o ${PN} ${PN}.c || die "compile"
+}
+
+src_install() {
+ dobin ide-smart || die
+ doman ide-smart.8
+ dodoc README
+}