summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2024-04-07 21:08:53 -0700
committerJohn Helmert III <ajak@gentoo.org>2024-04-07 21:10:22 -0700
commit86a3bd9a0f0e4b9059cd848200fb22340b0edf62 (patch)
tree541c0bbb6a5b42800f0c577ccd0ef2958bf36145 /app-admin/gopass
parentdev-python/pyfakefs: Bump to 5.4.0 (diff)
downloadgentoo-86a3bd9a0f0e4b9059cd848200fb22340b0edf62.tar.gz
gentoo-86a3bd9a0f0e4b9059cd848200fb22340b0edf62.tar.bz2
gentoo-86a3bd9a0f0e4b9059cd848200fb22340b0edf62.zip
app-admin/gopass: add 1.15.13
Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'app-admin/gopass')
-rw-r--r--app-admin/gopass/Manifest2
-rw-r--r--app-admin/gopass/gopass-1.15.13.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/app-admin/gopass/Manifest b/app-admin/gopass/Manifest
index 4364fb4ba686..e65f6f8ffda2 100644
--- a/app-admin/gopass/Manifest
+++ b/app-admin/gopass/Manifest
@@ -1,2 +1,4 @@
DIST gopass-1.15.11-deps.tar.xz 288006888 BLAKE2B 527cef72eb493425111c6fd0a872bb31c63381226c823143e5d722cb59172a08901a50fce7042d329370bc83dd66205833e85608d68ce9b2037db89eb1a1b8a7 SHA512 978c5a915d382b8fe6360744c45c696f8c3c571df1341496537be73896d100eda78be1630b2f4a3ccd73d828d566a483bc057a302683aa4ddf92f46b8fa49e03
DIST gopass-1.15.11.tar.gz 2319860 BLAKE2B 923be5effa8ca5a77a12bcd2692d2a07b68c6d068a579022e359a5f6e485813c37dc7e34acfeb1f0deec4e1075a54dd75b408ef0e07713cf7ffc2cfde2e9ac38 SHA512 ec3231f6cf903ba3a70f4721f04613ddf0e28e820c98a708c861ae68c993162a1346f62332132c00abd218f82f0ed0da0f8b86297427e813b0688a8eee5128be
+DIST gopass-1.15.13-deps.tar.xz 284979668 BLAKE2B 12e42b897dfc613de810cc4c42e2318b5cad013e14b007daba454b800092f6e408e5ca10731b14d895673cd9426b322d94615a45954e3a0871b0b46533b6f6c9 SHA512 5e4a2f564d0140d77cdaf52a3784d75984db8b68152bf7137d3fbd727238e9509d56d280ceb1106fa47198bb8bc52980637652c10bd95524063bf1e3e962fdfb
+DIST gopass-1.15.13.tar.gz 2328529 BLAKE2B 276ea675c7978ac1627cb313b595d9f252cc3aae29245eca758aed3b6632ddcdfa0da93cdc06f4c0767a2d5f58ded41fcccfac774b5001351bb4b743e976c595 SHA512 b7fcc7814ccad0cf0e3116eac848df080338e313ddcbb0cc8413cb353a1596b250aed427c97e791326e04c6c4241dbb529e112398218f2a905fc0fb48bc49963
diff --git a/app-admin/gopass/gopass-1.15.13.ebuild b/app-admin/gopass/gopass-1.15.13.ebuild
new file mode 100644
index 000000000000..a01fea7d6355
--- /dev/null
+++ b/app-admin/gopass/gopass-1.15.13.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module optfeature
+
+DESCRIPTION="a simple but powerful password manager for the terminal"
+HOMEPAGE="https://www.gopass.pw/"
+SRC_URI="https://github.com/gopasspw/gopass/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~ajak/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="MIT Apache-2.0 BSD MPL-2.0 BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~riscv ~x86"
+
+DEPEND=">=dev-lang/go-1.18"
+RDEPEND="
+ dev-vcs/git
+ >=app-crypt/gnupg-2
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.15.3-skip-tests.patch"
+)
+
+src_test() {
+ # https://github.com/gopasspw/gopass/blob/v1.15.3/.github/workflows/build.yml#L38
+ git config --global user.name nobody || die
+ git config --global user.email foo.bar@example.org || die
+
+ default
+}
+
+src_install() {
+ emake install DESTDIR="${ED}/usr"
+ einstalldocs
+}
+
+pkg_postinst() {
+ optfeature "browser integration" app-admin/gopass-jsonapi
+ optfeature "git credentials helper" app-admin/git-credential-gopass
+ optfeature "haveibeenpwnd.com integration" app-admin/gopass-hibp
+ optfeature "summon secrets helper" app-admin/gopass-summon-provider
+}