summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Pavljuchenkov (SpiderX) <spiderx@spiderx.dp.ua>2022-07-07 14:14:10 +0300
committerMatthew Smith <matthew@gentoo.org>2022-07-09 13:26:27 +0100
commita5a8086d30e688b6e8df324fac93363a30b18480 (patch)
treea6e63d3beb7e53acc5d2da3b6c5e2ab26c5173a4 /app-admin/doctl
parentdev-libs/libtpms: add 0.9.5 (diff)
downloadgentoo-a5a8086d30e688b6e8df324fac93363a30b18480.tar.gz
gentoo-a5a8086d30e688b6e8df324fac93363a30b18480.tar.bz2
gentoo-a5a8086d30e688b6e8df324fac93363a30b18480.zip
app-admin/doctl: version bump to 1.78
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Vladimir Pavljuchenkov <spiderx@spiderx.dp.ua> Closes: https://github.com/gentoo/gentoo/pull/26259 Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'app-admin/doctl')
-rw-r--r--app-admin/doctl/Manifest1
-rw-r--r--app-admin/doctl/doctl-1.78.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-admin/doctl/Manifest b/app-admin/doctl/Manifest
index 3d24a516bf39..36810eadc6d9 100644
--- a/app-admin/doctl/Manifest
+++ b/app-admin/doctl/Manifest
@@ -1,2 +1,3 @@
DIST doctl-1.76.2.tar.gz 5648377 BLAKE2B 1ec89adb5ad187ccc6b66d077dda57ca4065bc1a5981a0f2549913532f6bcc6d1f48c3cc56c100c1b6c55f698ffcf3f2c639888ccaab30948384ce800181b332 SHA512 d7efc587843cd87f3ac17b974858ea688377ca6f0cd3d4b7430c47a1e8b825cc05f4d9107d7062f5e52fe3c267ec6bbd19a8b1d773a15f1d7ab653087ce13bba
DIST doctl-1.77.0.tar.gz 5654010 BLAKE2B 809189c9fdfa1e81e75847e57fe5967f0d3ca476fdb7a2e72ffba1b4bb81ecdc2ce07b4b05f4f1f898104cd9e919d6bdba664d4ae0cc97adea6863379789aa08 SHA512 a53e8e3179ec467cd0617a25ab985fe36e41135a824688a947b15c0565fb2d8364c59a295573043039b79b701bb4d5a9ec5461450fa0e7c5a24f10ece53c6f71
+DIST doctl-1.78.0.tar.gz 5658172 BLAKE2B 3213219b1cfbc395c742a59a6bee1c6232f222455ac126de9ce51470a56ebaa9680de4d332cd31580a7ddb9f748b19a8abadef17ff6ea4265dffc2c42b1bb16d SHA512 193fe775885c78312eb6ba14bd34d109ee31acf41cfe68dbacbf6ab19864509b774c658aecf7a61d470598ca89829a6737ea6796eb970b3075d8f37aef747dbe
diff --git a/app-admin/doctl/doctl-1.78.0.ebuild b/app-admin/doctl/doctl-1.78.0.ebuild
new file mode 100644
index 000000000000..3f5680240a83
--- /dev/null
+++ b/app-admin/doctl/doctl-1.78.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 edo go-module
+
+DESCRIPTION="A command line tool for DigitalOcean services"
+HOMEPAGE="https://github.com/digitalocean/doctl"
+SRC_URI="https://github.com/digitalocean/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 MIT BSD BSD-2 ISC MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ LDFLAGS="-X github.com/digitalocean/doctl.Major=$(ver_cut 1)
+ -X github.com/digitalocean/doctl.Minor=$(ver_cut 2)
+ -X github.com/digitalocean/doctl.Patch=$(ver_cut 3-)
+ -X github.com/digitalocean/doctl.Label=release"
+ GOFLAGS="-v -x -mod=vendor" ego build -ldflags "$LDFLAGS" ./cmd/...
+
+ local completion
+ for completion in bash zsh fish ; do
+ edo ./doctl completion ${completion} > doctl.${completion} \
+ || die "completion for ${completion} failed"
+ done
+}
+
+src_test() {
+ GOFLAGS="-v -x -mod=vendor" ego test -work ./do/... ./pkg/... .
+}
+
+src_install() {
+ einstalldocs
+ dobin doctl
+
+ newbashcomp doctl.bash doctl
+ insinto /usr/share/zsh/site-functions
+ newins doctl.zsh _doctl
+ insinto /usr/share/fish/completion
+ newins doctl.fish doctl
+}