summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2023-05-16 17:31:15 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2023-05-16 17:31:15 -0500
commitc65ead6863c146a97f54f8953882543239e169df (patch)
treeeee723834addbb3797e1c166c852e50997b98f61 /app-admin/ansible
parentapp-admin/ansible-core: add 2.15.0 (diff)
downloadgentoo-c65ead6863c146a97f54f8953882543239e169df.tar.gz
gentoo-c65ead6863c146a97f54f8953882543239e169df.tar.bz2
gentoo-c65ead6863c146a97f54f8953882543239e169df.zip
app-admin/ansible: add 7.5.0
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/ansible')
-rw-r--r--app-admin/ansible/Manifest1
-rw-r--r--app-admin/ansible/ansible-7.5.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-admin/ansible/Manifest b/app-admin/ansible/Manifest
index 9a4720992206..2e5f190236a2 100644
--- a/app-admin/ansible/Manifest
+++ b/app-admin/ansible/Manifest
@@ -1,2 +1,3 @@
DIST ansible-6.7.0.tar.gz 36371372 BLAKE2B 75cb14f158c36ded8313a1c5b798838afdf3a38ffc8e29a87c8e1e3e74c9aeca827432397ad83ed23a1d3aeaaef91822cc3c23aa226a307d93f84f54b25d71bb SHA512 676baf03626d5bf36aea7117d39ef71ba7878ab6bccdec1ee199bd699d559a5f3f6a0d9032ef120204093677b7fbbe1b575529d3aa692acd1a4447f9c2715f3a
DIST ansible-7.4.0.tar.gz 37352820 BLAKE2B 33d3affa052e509348c981920597ab13f3181dee1ab46eda764e0a68df2edeefbcb62cec57e62da559bfe2b5e7efdb95eba1b602efe198bfad8dd0301e66c7df SHA512 c77aebb54676b669305905c969fa5afac9e1262bfefa358de7fee0fb3ef89d0306c599acb2225cdb4209c53df16c307d438cc628299aec494c70cba166eb3cbb
+DIST ansible-7.5.0.tar.gz 37716844 BLAKE2B 47f6fcb744a65b3dd4d8619acd0ca23561bb6f1e3eb12d038e212a0bd92e98e0c93ab5f08c463cca357c568cccb19eb1bfd764d91cf83d79564039525ee90bc7 SHA512 0246d5beabbe26733978d83359b5647727c833ca0dd3f84f86f61f906e62e96178bffb82e39a2a48ffc442e01f3ab8335f5bb7c4649c872373831ad2deaf9572
diff --git a/app-admin/ansible/ansible-7.5.0.ebuild b/app-admin/ansible/ansible-7.5.0.ebuild
new file mode 100644
index 000000000000..0cefb7045e40
--- /dev/null
+++ b/app-admin/ansible/ansible-7.5.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://www.ansible.com/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86 ~x64-macos"
+RESTRICT="test"
+
+RDEPEND=">=app-admin/ansible-core-2.14.0
+ <app-admin/ansible-core-2.15"
+
+python_compile() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
+python_install() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_install
+}