summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-07-19 11:32:44 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-07-19 11:32:57 -0500
commit5e008cd645cd19a44e02698a988570c5bbe7ef84 (patch)
treeb546d1c5a98bad00d0f36af8af76d373acbf0d4a /app-admin/ansible/ansible-6.1.0.ebuild
parentapp-admin/ansible-base: 2.13.2 bump (diff)
downloadgentoo-5e008cd645cd19a44e02698a988570c5bbe7ef84.tar.gz
gentoo-5e008cd645cd19a44e02698a988570c5bbe7ef84.tar.bz2
gentoo-5e008cd645cd19a44e02698a988570c5bbe7ef84.zip
app-admin/ansible: 6.1.0 bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'app-admin/ansible/ansible-6.1.0.ebuild')
-rw-r--r--app-admin/ansible/ansible-6.1.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-admin/ansible/ansible-6.1.0.ebuild b/app-admin/ansible/ansible-6.1.0.ebuild
new file mode 100644
index 000000000000..6edb26b0dbf7
--- /dev/null
+++ b/app-admin/ansible/ansible-6.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://www.ansible.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~x64-macos"
+RESTRICT="test"
+
+RDEPEND=">=app-admin/ansible-base-2.13.0
+ <app-admin/ansible-base-2.14"
+
+python_compile() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
+python_install() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_install
+}