summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-12-28 06:19:26 +0000
committerSam James <sam@gentoo.org>2023-12-28 14:57:30 +0000
commitf93933a4304fdba5bf7a034409bad09e026c9ff3 (patch)
treeeaa471ab0d82861c89ea061623a8b3d2c6fec3aa
parentsys-devel/gdb: drop 13.2-r1 (diff)
downloadgentoo-f93933a4304fdba5bf7a034409bad09e026c9ff3.tar.gz
gentoo-f93933a4304fdba5bf7a034409bad09e026c9ff3.tar.bz2
gentoo-f93933a4304fdba5bf7a034409bad09e026c9ff3.zip
sys-fs/bees: drop 0.9.3
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sys-fs/bees/Manifest1
-rw-r--r--sys-fs/bees/bees-0.9.3.ebuild112
2 files changed, 0 insertions, 113 deletions
diff --git a/sys-fs/bees/Manifest b/sys-fs/bees/Manifest
index f00537cdc1c0..95df53082d6c 100644
--- a/sys-fs/bees/Manifest
+++ b/sys-fs/bees/Manifest
@@ -1,2 +1 @@
DIST bees-0.10.tar.gz 177509 BLAKE2B 269cf65d5250a07297dfaee6c0fd6bc25199d63fe423d63ce39df8bcdb64d6f8110a0e03d0dc7dc1b105a8886f2a9364da8878481546eaa8dbf3dc46abc569ed SHA512 77a4ae3d66430c2d9dc0351c16c60bad95f21e238fc00f5f5787f55929ba75ee25212ac4bb4a3e4a9419cec27bbcfd2987aa925a54bc2872609b38a698dbedc3
-DIST bees-0.9.3.tar.gz 177265 BLAKE2B f0363771647ee07b12afe3ef44c1453e4677e12b051e33a81517a6044a459237b72712a09b31895147cd171a649ba15fc75676f34df46c9520248eae09e193e1 SHA512 5517773478cd56915ec3aee6542f6128a0f72b10aa96708d20778a76a427890bdfd9d8ba775b9dff3395d2e203fa2995070f9aca509b8150b9a9bcf076828ebb
diff --git a/sys-fs/bees/bees-0.9.3.ebuild b/sys-fs/bees/bees-0.9.3.ebuild
deleted file mode 100644
index a1b15c2ef627..000000000000
--- a/sys-fs/bees/bees-0.9.3.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit linux-info systemd toolchain-funcs
-
-DESCRIPTION="Best-Effort Extent-Same, a btrfs dedup agent"
-HOMEPAGE="https://github.com/Zygo/bees"
-
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/Zygo/bees.git"
-else
- SRC_URI="https://github.com/Zygo/bees/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm64"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE=""
-
-DEPEND="
- >=sys-apps/util-linux-2.30.2
- >=sys-fs/btrfs-progs-4.20.2
-"
-RDEPEND="${DEPEND}"
-
-CONFIG_CHECK="~BTRFS_FS"
-ERROR_BTRFS_FS="CONFIG_BTRFS_FS: bees does currently only work with btrfs"
-
-PATCHES=(
- "${FILESDIR}/0001-HACK-crucible-Work-around-kernel-memory-fragmentatio.patch"
-)
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != buildonly ]]; then
- if kernel_is -lt 4 11; then
- ewarn "With kernel versions below 4.11, bees may severely degrade system performance"
- ewarn "and responsiveness. Especially, the kernel may deadlock while bees is"
- ewarn "running, it's recommended to run at least kernel 4.11."
- ewarn
- elif kernel_is -lt 4 14 29; then
- ewarn "With kernel versions below 4.14.29, bees may generate a lot of bogus WARN_ON()"
- ewarn "messages in the kernel log. These messages can be ignored and this is fixed"
- ewarn "with more recent kernels:"
- ewarn "# WARNING: CPU: 3 PID: 18172 at fs/btrfs/backref.c:1391 find_parent_nodes+0xc41/0x14e0"
- ewarn
- elif kernel_is -lt 5 7 0; then
- ewarn "With kernel versions below 5.4.96 and 5.7, the kernel may hold file system"
- ewarn "locks for a long time while at the same time CPU usage increases when bees is"
- ewarn "operating. bees tries to avoid this behavior by excluding very common extents"
- ewarn "from deduplication. This has only a minimal impact on dedupe effectiveness."
- ewarn
- fi
- if kernel_is -lt 5 1 0; then
- ewarn "IMPORTANT: With kernel versions below 5.1.0, you may experience data corruption"
- ewarn "due to bees using compression in btrfs. You are adviced to use a chronologically"
- ewarn "later kernel, that includes older LTS versions released after 5.0.4:"
- ewarn "Fixed in: 5.1+, 5.0.4+, 4.19.31+, 4.14.108+, 4.9.165+, 4.4.177+, 3.18.137+"
- ewarn "# commit 8e92821 btrfs: fix corruption reading shared and compressed extents after hole punching"
- ewarn
- fi
- if kernel_is -lt 5 4 19; then
- ewarn "With kernel versions below 5.4.19, bees may trigger a btrfs bug when running"
- ewarn "btrfs-balance in parallel. This may lead to meta-data corruption in the worst"
- ewarn "case. Especially, kernels 5.1.21 and 5.2.21 should be avoided. Kernels 5.0.x"
- ewarn "after 5.0.21 should be safe. In the best case, affected kernels may force"
- ewarn "the device RO without writing corrupted meta-data. More details:"
- ewarn "https://github.com/Zygo/bees/blob/master/docs/btrfs-kernel.md"
- ewarn
- fi
- if kernel_is -gt 5 15 106; then
- if kernel_is -lt 6 3 10; then
- ewarn "With kernel versions 5.15.107 or later, there is a memory fragmentation"
- ewarn "issue with LOGICAL_INO which can lead to cache thrashing and cause IO"
- ewarn "latency spikes. This version ships with a work-around at the cost of not"
- ewarn "handling highly duplicated filesystems that well. More details:"
- ewarn "https://github.com/Zygo/bees/issues/260"
- ewarn
- fi
- fi
-
- elog "Bees recommends running the latest current kernel for performance and"
- elog "reliability reasons, see README.md."
- fi
-}
-
-src_prepare() {
- default
- sed -i 's/ -Werror//' makeflags || die
-}
-
-src_configure() {
- tc-export CC CXX AR
- cat >localconf <<-EOF || die
- ETC_PREFIX="${EPREFIX}/etc"
- LIBEXEC_PREFIX="${EPREFIX}/usr/libexec"
- PREFIX="${EPREFIX}/usr"
- SYSTEMD_SYSTEM_UNIT_DIR="$(systemd_get_systemunitdir)"
- DEFAULT_MAKE_TARGET=all
- EOF
- if [[ ${PV} != "9999" ]] ; then
- echo BEES_VERSION=v${PV} >>localconf || die
- fi
-}
-
-src_compile() {
- default
- # localconf quotes leak in the systemd unit but are still needed for spaces
- sed -i 's/"//g' scripts/beesd@.service || die
-}