summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-06-26 21:48:42 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-06-26 21:54:53 +0200
commitddd22799bee59a8f79497de7a9590e085f8760d1 (patch)
tree50490f9d2f9bd9b6f5dcb7dae45f6d9ed5b26992
parentdev-perl/Monitoring-Plugin: Add build fix for Perl 5.26, bug 617116 (diff)
downloadgentoo-ddd22799bee59a8f79497de7a9590e085f8760d1.tar.gz
gentoo-ddd22799bee59a8f79497de7a9590e085f8760d1.tar.bz2
gentoo-ddd22799bee59a8f79497de7a9590e085f8760d1.zip
media-libs/libgltf: 0.1.0 version bump
Package-Manager: Portage-2.3.6, Repoman-2.3.1
-rw-r--r--media-libs/libgltf/Manifest1
-rw-r--r--media-libs/libgltf/libgltf-0.1.0.ebuild50
-rw-r--r--media-libs/libgltf/libgltf-9999.ebuild7
3 files changed, 55 insertions, 3 deletions
diff --git a/media-libs/libgltf/Manifest b/media-libs/libgltf/Manifest
index b18edd4af070..6fbb14013aff 100644
--- a/media-libs/libgltf/Manifest
+++ b/media-libs/libgltf/Manifest
@@ -1 +1,2 @@
DIST libgltf-0.0.2.tar.bz2 538040 SHA256 d1cc7297ed1921aa969e26413b4c4e18afc882ce4d2f5a2aa2a2905706f7206b SHA512 74ca5e5e0f38ee5a67e870b49f4adf6c9710dc696afb776149618c05d15e3527d605143230f7ceacd199b609bcbb683cfc72d8e4ef22ba5b9ca777c8a2b53dcf WHIRLPOOL fbac1dc41cab63d4f322893d1b55d513fe8eefad5d625db703134dc429b3b87b5b6d36c481810d6e819c8f8213846b700d318421ac7858347c5ddf1cd875a246
+DIST libgltf-0.1.0.tar.gz 736163 SHA256 119e730fbf002dd0eaafa4930167267d7d910aa17f29979ca9ca8b66625fd2da SHA512 c4ef222d638a3f691bcce493776ef451830168ef0569c417f0acdd305e5f261500767943f92a3e65d6b00aecf6c02bdae56f52e0943b8d36490ef66474d9252a WHIRLPOOL 3994d7200b351dbc73c1041aad1ff802344226a61c5d46e366f5f42ecf3d5fbd5410c40d2eb9cd6b0b92d25f496ebf06cdc9c942470d6b6a99c9e69ff31d9106
diff --git a/media-libs/libgltf/libgltf-0.1.0.ebuild b/media-libs/libgltf/libgltf-0.1.0.ebuild
new file mode 100644
index 000000000000..320dc63b2873
--- /dev/null
+++ b/media-libs/libgltf/libgltf-0.1.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGIT_REPO_URI="git://gerrit.libreoffice.org/libgltf.git"
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
+
+DESCRIPTION="C++ Library for rendering OpenGL models stored in glTF format"
+HOMEPAGE="http://www.libreoffice.org https://gerrit.libreoffice.org/gitweb?p=libgltf.git"
+[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+[[ ${PV} == 9999 ]] || \
+KEYWORDS="~amd64 ~x86"
+IUSE="debug test"
+
+RDEPEND="
+ >=media-libs/libepoxy-1.3.1
+ virtual/opengl
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ media-libs/glm
+ sys-devel/libtool
+ virtual/pkgconfig
+"
+
+# testsuite not in tarball
+# only in git; unsure
+RESTRICT="test"
+
+src_prepare() {
+ default
+ [[ -d m4 ]] || mkdir "m4"
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-werror \
+ $(use_enable debug) \
+ $(use_enable test tests)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/media-libs/libgltf/libgltf-9999.ebuild b/media-libs/libgltf/libgltf-9999.ebuild
index ee2dc78b474b..320dc63b2873 100644
--- a/media-libs/libgltf/libgltf-9999.ebuild
+++ b/media-libs/libgltf/libgltf-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -7,8 +7,8 @@ EGIT_REPO_URI="git://gerrit.libreoffice.org/libgltf.git"
[[ ${PV} == 9999 ]] && inherit autotools git-r3
DESCRIPTION="C++ Library for rendering OpenGL models stored in glTF format"
-HOMEPAGE="http://www.libreoffice.org"
-[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.libreoffice.org https://gerrit.libreoffice.org/gitweb?p=libgltf.git"
+[[ ${PV} == 9999 ]] || SRC_URI="http://dev-www.libreoffice.org/src/${PN}/${P}.tar.gz"
LICENSE="MPL-2.0"
SLOT="0"
@@ -40,6 +40,7 @@ src_prepare() {
src_configure() {
econf \
--disable-werror \
+ $(use_enable debug) \
$(use_enable test tests)
}