summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-03-13 12:24:42 -0500
committerMatt Turner <mattst88@gentoo.org>2021-03-13 13:08:12 -0500
commitc052229f15357863a90206fafe9e9352264d3047 (patch)
tree8764aa5054e1183da45f8ff796d13e6418333020
parentnet-irc/telepathy-idle: Version bump to 0.2.2 (diff)
downloadgentoo-c052229f15357863a90206fafe9e9352264d3047.tar.gz
gentoo-c052229f15357863a90206fafe9e9352264d3047.tar.bz2
gentoo-c052229f15357863a90206fafe9e9352264d3047.zip
net-libs/farstream: Version bump to 0.2.9
Closes: https://bugs.gentoo.org/713226 Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--net-libs/farstream/Manifest1
-rw-r--r--net-libs/farstream/farstream-0.2.9.ebuild70
-rw-r--r--net-libs/farstream/files/farstream-0.2.9-make43.patch38
-rw-r--r--net-libs/farstream/metadata.xml3
4 files changed, 112 insertions, 0 deletions
diff --git a/net-libs/farstream/Manifest b/net-libs/farstream/Manifest
index 21d215588d15..0ba8ee3c392c 100644
--- a/net-libs/farstream/Manifest
+++ b/net-libs/farstream/Manifest
@@ -1 +1,2 @@
DIST farstream-0.2.8.tar.gz 1315548 BLAKE2B 3f90e6150fd13d02369837b019ad3b935165130b8396133697d0819861f5a5ed79c6eab3efdc3bcc5a6887807285bece21f188bc756ec3cd64a57f5682f5b348 SHA512 7ec5c57f8778f4107cb628dbf411e38b726152cf78920127dff4423239ff7e4980b6b4f938abba2aa21ab984b1e3053e7e648611322a0ce94df0af576df99a7e
+DIST farstream-0.2.9.tar.gz 1334833 BLAKE2B 3c23f9534cb8578acd82bb0f7308891e0448cbf5a5b986f27d14e4d727a1e52f4268532c44dcc84e2a1db19504840ddac128c9bd0a731f06e2972d233d8781b9 SHA512 8840725d2f1de59bebc8c49cf68a6712822a4e7b6ba9078713f80e3c35a39135565a1a885edab43a562f895e11b8f5d8d666d57d9b3814dabb661f46498515bd
diff --git a/net-libs/farstream/farstream-0.2.9.ebuild b/net-libs/farstream/farstream-0.2.9.ebuild
new file mode 100644
index 000000000000..4c76af4f7c7f
--- /dev/null
+++ b/net-libs/farstream/farstream-0.2.9.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+GNOME2_EAUTORECONF=yes
+inherit gnome2
+
+DESCRIPTION="Audio/video conferencing framework specifically designed for instant messengers"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/Farstream"
+SRC_URI="https://freedesktop.org/software/farstream/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+introspection test upnp valgrind"
+SLOT="0.2/5" # .so version
+
+# Tests need shmsink from gst-plugins-bad, which isn't packaged
+# FIXME: do an out-of-tree build for tests if USE=-msn
+RESTRICT="test"
+
+COMMON_DEPEND="
+ >=media-libs/gstreamer-1.4:1.0
+ >=media-libs/gst-plugins-base-1.4:1.0
+ >=dev-libs/glib-2.40:2
+ >=net-libs/libnice-0.1.8
+ introspection? ( >=dev-libs/gobject-introspection-0.10.11:= )
+ upnp? ( >=net-libs/gupnp-igd-0.2:= )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=media-libs/gst-plugins-bad-1.4:1.0
+ >=media-libs/gst-plugins-good-1.4:1.0
+ media-plugins/gst-plugins-srtp:1.0
+ media-plugins/gst-plugins-libnice:1.0
+"
+DEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
+ test? (
+ media-libs/gst-plugins-base:1.0[vorbis]
+ media-libs/gst-plugins-good:1.0
+ )
+ valgrind? ( dev-util/valgrind )
+"
+BDEPEND="
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.18
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.2.9-make43.patch
+)
+
+src_configure() {
+ plugins="fsrawconference,fsrtpconference,fsmsnconference,fsrtpxdata,fsfunnel,fsrtcpfilter,fsvideoanyrate"
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable upnp gupnp) \
+ $(use_enable valgrind) \
+ --with-plugins=${plugins}
+}
+
+src_compile() {
+ # Prevent sandbox violations, bug #539224
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744135
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744134
+ addpredict /dev
+ gnome2_src_compile
+}
diff --git a/net-libs/farstream/files/farstream-0.2.9-make43.patch b/net-libs/farstream/files/farstream-0.2.9-make43.patch
new file mode 100644
index 000000000000..20a84f6e59d6
--- /dev/null
+++ b/net-libs/farstream/files/farstream-0.2.9-make43.patch
@@ -0,0 +1,38 @@
+From 54987d445ea714b467d901b7daf8c09ed0644189 Mon Sep 17 00:00:00 2001
+From: Debarshi Ray <debarshir@freedesktop.org>
+Date: Thu, 12 Mar 2020 14:07:23 +0100
+Subject: [PATCH] build: Adapt to backwards incompatible change in GNU Make 4.3
+
+GNU Make 4.3 has a backwards incompatible change affecting the use of
+number signs or hashes (ie., #) inside function invocations. See:
+https://lists.gnu.org/archive/html/info-gnu/2020-01/msg00004.html
+
+In this case, it would expand the '\#' in the '\n\#include \"$(h)\"'
+argument to the foreach call to '\#', not '#'. This would lead to
+spurious backslashes in front of the '#include' directives in the
+generated fs-enumtypes.c file.
+
+Spotted by Ernestas Kulik.
+
+https://gitlab.freedesktop.org/farstream/farstream/-/merge_requests/4
+---
+ common-modified/gst-glib-gen.mak | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/common-modified/gst-glib-gen.mak b/common-modified/gst-glib-gen.mak
+index 14f1ba37..2247a41c 100644
+--- a/common-modified/gst-glib-gen.mak
++++ b/common-modified/gst-glib-gen.mak
+@@ -6,7 +6,8 @@
+ #glib_gen_prefix=gst_color_balance
+ #glib_gen_basename=colorbalance
+
+-enum_headers=$(foreach h,$(glib_enum_headers),\n\#include \"$(h)\")
++hash:=\#
++enum_headers=$(foreach h,$(glib_enum_headers),\n$(hash)include \"$(h)\")
+
+ # these are all the rules generating the relevant files
+ $(glib_gen_basename)-enumtypes.h: $(glib_enum_headers)
+--
+GitLab
+
diff --git a/net-libs/farstream/metadata.xml b/net-libs/farstream/metadata.xml
index 39980802b1da..5c42c302ab3f 100644
--- a/net-libs/farstream/metadata.xml
+++ b/net-libs/farstream/metadata.xml
@@ -5,4 +5,7 @@
<email>gnome@gentoo.org</email>
<name>Gentoo GNOME Desktop</name>
</maintainer>
+<use>
+<flag name="valgrind">Compile in valgrind memory hints</flag>
+</use>
</pkgmetadata>